python3-openssl: Add dependency on ca-certs 12230/head
authorJeffery To <jeffery.to@gmail.com>
Tue, 19 May 2020 20:30:45 +0000 (04:30 +0800)
committerJeffery To <jeffery.to@gmail.com>
Tue, 19 May 2020 20:30:45 +0000 (04:30 +0800)
The ssl module assumes OpenSSL can load the default trust anchors (root
CA certificates).

From https://github.com/openwrt/packages/issues/12209

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python3/Makefile
lang/python/python3/files/python3-package-openssl.mk

index debb435ee9157c93b77130ed2e97ec48b6c756b9..a0c46ffcc0a47dd62f8feee6522256d91d57f7d6 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 include ../python3-version.mk
 
 PKG_NAME:=python3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
index 6971993f73dca5c7780576b6ac2622de2ab4c525..4d13afd2026f1bc6069da1825e2d938757e7c8c7 100644 (file)
@@ -8,7 +8,7 @@
 define Package/python3-openssl
 $(call Package/python3/Default)
   TITLE:=Python $(PYTHON3_VERSION) SSL module
-  DEPENDS:=+python3-light +libopenssl
+  DEPENDS:=+python3-light +libopenssl +ca-certs
 endef
 
 $(eval $(call Py3BasePackage,python3-openssl, \