ramips: enable LZMA loader to fix Linksys RE6500 boot
authorMark King <mark@vemek.co>
Sun, 25 Sep 2022 20:53:52 +0000 (21:53 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 3 Oct 2022 17:51:50 +0000 (19:51 +0200)
At some point after 21.02.3 and before 22.03.0, the size limits of the
Linksys RE6500 were reached and prevent booting from the 22.03.0 release
or builds of current SNAPSHOT. This patch allows builds of master to boot
again and has been tested on my device.

Fixes: #8577
Signed-off-by: Mark King <mark@vemek.co>
(cherry picked from commit bf5b1a53d4ff3f1d742f9ece1ab16555280417ec)

target/linux/ramips/image/mt7621.mk

index 8860be11b8c879c067901cf6642a133b27b1e3b2..c07ab39afdebd38b7e1764b86eaceb4e2108768c 100644 (file)
@@ -1108,6 +1108,7 @@ TARGET_DEVICES += linksys_ea8100-v2
 
 define Device/linksys_re6500
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := RE6500