Merge pull request #15747 from neheb/tiff2
authorJiri Slachta <jiri@slachta.eu>
Sat, 19 Jun 2021 20:07:42 +0000 (22:07 +0200)
committerGitHub <noreply@github.com>
Sat, 19 Jun 2021 20:07:42 +0000 (22:07 +0200)
tiff: update to 4.2.3

libs/tiff/Makefile
libs/tiff/patches/001-autoconf-compat.patch [deleted file]
libs/tiff/patches/005-fix-ftell-macro.patch [deleted file]

index 98f96aa07861667a4f41eed3592bd01b5a37bae6..704f9197994b5da0f25f4f8d626077856b47130c 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tiff
-PKG_VERSION:=4.2.0
-PKG_RELEASE:=2
+PKG_VERSION:=4.3.0
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.osgeo.org/libtiff
-PKG_HASH:=eb0484e568ead8fa23b513e9b0041df7e327f4ee2d22db5a533929dfc19633cb
+PKG_HASH:=0e46e5acb087ce7d1ac53cf4f56a09b221537fc86dfc5daaad1c2e89e1b37ac8
 
 PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
 PKG_LICENSE:=BSD-3-Clause
diff --git a/libs/tiff/patches/001-autoconf-compat.patch b/libs/tiff/patches/001-autoconf-compat.patch
deleted file mode 100644 (file)
index fd779ea..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -25,7 +25,7 @@
- docdir = $(LIBTIFF_DOCDIR)
--AUTOMAKE_OPTIONS = 1.12 dist-zip foreign
-+AUTOMAKE_OPTIONS = dist-zip foreign
- ACLOCAL_AMFLAGS = -I m4
- docfiles = \
-@@ -60,7 +60,7 @@ distcheck-hook:
-       rm -rf $(distdir)/_build/cmake
-       rm -rf $(distdir)/_inst/cmake
--SUBDIRS = port libtiff tools build contrib test man html
-+SUBDIRS = port libtiff tools build contrib
- release:
-       (rm -f $(top_srcdir)/RELEASE-DATE && echo $(LIBTIFF_RELEASE_DATE) > $(top_srcdir)/RELEASE-DATE)
---- a/test/Makefile.am
-+++ b/test/Makefile.am
-@@ -23,7 +23,7 @@
- # Process this file with automake to produce Makefile.in.
--AUTOMAKE_OPTIONS = 1.12 color-tests parallel-tests foreign
-+AUTOMAKE_OPTIONS = color-tests parallel-tests foreign
- LIBTIFF = $(top_builddir)/libtiff/libtiff.la
diff --git a/libs/tiff/patches/005-fix-ftell-macro.patch b/libs/tiff/patches/005-fix-ftell-macro.patch
deleted file mode 100644 (file)
index d5acde9..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/libtiff/tiffiop.h
-+++ b/libtiff/tiffiop.h
-@@ -302,7 +302,7 @@ struct tiff {
- */
- #if defined(HAVE_FSEEKO)
- #  define fseek(stream,offset,whence)  fseeko(stream,offset,whence)
--#  define ftell(stream,offset,whence)  ftello(stream,offset,whence)
-+#  define ftell(stream)  ftello(stream)
- #endif
- #endif
- #if defined(__WIN32__) && \