open-plc-utils: fix musl and fortify source compatibility 1483/head
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 26 Jun 2015 14:38:42 +0000 (16:38 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 26 Jun 2015 14:41:26 +0000 (16:41 +0200)
 - Include `poll.h` at the top of `ether/readpacket.c` to avoid nested
   declaration errors caused by fortify source headers
 - Add missing `sys/select.h` include to `serial/serial.c`

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
utils/open-plc-utils/Makefile
utils/open-plc-utils/patches/100-musl-compat.patch [new file with mode: 0644]

index 1c8ef9d51db115420730f8cb86b89d2b1491a78d..480711a74756ab49edadb9de339220b7fe843a88 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013-2014 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=open-plc-utils
-PKG_VERSION:=2015-02-23
+PKG_VERSION:=2015-06-26
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
diff --git a/utils/open-plc-utils/patches/100-musl-compat.patch b/utils/open-plc-utils/patches/100-musl-compat.patch
new file mode 100644 (file)
index 0000000..c20c0a1
--- /dev/null
@@ -0,0 +1,33 @@
+--- a/ether/readpacket.c
++++ b/ether/readpacket.c
+@@ -70,6 +70,10 @@
+ #include <memory.h>
+ #include <errno.h>
++#if defined (__linux__)
++#include <poll.h>
++#endif
++
+ #include "../ether/channel.h"
+ #include "../tools/memory.h"
+ #include "../tools/error.h"
+@@ -95,8 +99,6 @@ ssize_t readpacket (struct channel const
+ #elif defined (__linux__)
+-#include <sys/poll.h>
+-
+       struct pollfd pollfd =
+       {
+               channel->fd,
+--- a/serial/serial.c
++++ b/serial/serial.c
+@@ -69,6 +69,8 @@
+ #if defined (WIN32)
+ #include <Windows.h>
++#else
++#include <sys/select.h>
+ #endif
+ /*====================================================================*