freeswitch-stable: add a few autoconf_bools
authorSebastian Kemper <sebastian_ml@gmx.net>
Fri, 22 Dec 2017 21:51:56 +0000 (22:51 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Fri, 22 Dec 2017 21:51:58 +0000 (22:51 +0100)
- Use autoconf_bool instead of manually calling configure switches.
- Revision bump.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/freeswitch-stable/Makefile

index 273243133185f1ae0c5f0e8c4e0a8d332cb23356..0a67fee385fd0fa30028f0a7fcf89518be59d907 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PRG_NAME:=freeswitch
 PKG_NAME:=$(PRG_NAME)-stable
 PKG_VERSION:=1.6.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 
 PKG_SOURCE:=$(PRG_NAME)-$(PKG_VERSION).tar.xz
@@ -616,17 +616,18 @@ CONFIGURE_ARGS+= \
        --with-logfiledir=/tmp/$(PRG_NAME)/log \
        --with-recordingsdir=/tmp/$(PRG_NAME)/recordings \
        --with-storagedir=/tmp/$(PRG_NAME)/storage \
+       $(call autoconf_bool,CONFIG_FS_STABLE_WITH_DEBUG,debug) \
+       $(call autoconf_bool,CONFIG_FS_STABLE_WITH_LIBYUV,libyuv) \
        $(call autoconf_bool,CONFIG_FS_STABLE_WITH_ODBC,core-odbc-support) \
+       $(call autoconf_bool,CONFIG_FS_STABLE_WITH_PGSQL,core-pgsql-support) \
        $(call autoconf_bool,CONFIG_FS_STABLE_WITH_SRTP,srtp) \
+       $(call autoconf_bool,CONFIG_FS_STABLE_WITH_VPX,libvpx) \
        $(call autoconf_bool,CONFIG_FS_STABLE_WITH_ZRTP,zrtp) \
-       $(if $(CONFIG_FS_STABLE_WITH_DEBUG),,--disable-debug) \
        $(if $(CONFIG_FS_STABLE_WITH_FREETYPE),,--without-freetype) \
-       $(if $(CONFIG_FS_STABLE_WITH_LIBYUV),,--disable-libyuv) \
        $(if $(CONFIG_FS_STABLE_WITH_ODBC),--with-odbc-lib="$(STAGING_DIR)$(FS_STABLE_LIB_DIR)") \
        $(if $(CONFIG_FS_STABLE_WITH_ODBC),--with-odbc="$(STAGING_DIR)/usr") \
-       $(if $(CONFIG_FS_STABLE_WITH_PGSQL),--enable-core-pgsql-support,--without-pgsql) \
-       $(if $(CONFIG_FS_STABLE_WITH_PNG),,--without-png) \
-       $(if $(CONFIG_FS_STABLE_WITH_VPX),,--disable-libvpx)
+       $(if $(CONFIG_FS_STABLE_WITH_PGSQL),,--without-pgsql) \
+       $(if $(CONFIG_FS_STABLE_WITH_PNG),,--without-png)
 
 ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-misc-python-esl)$(CONFIG_PACKAGE_$(PKG_NAME)-mod-python),)
 CONFIGURE_ARGS+= \