apache: add gettid support 11250/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Tue, 4 Feb 2020 21:00:55 +0000 (22:00 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Tue, 4 Feb 2020 21:00:57 +0000 (22:00 +0100)
gettid happens to be supported by all glibc, musl and uclibc, but
configure cannot detect it when cross-compiling. This adds a configure
variable for it.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/apache/Makefile

index 107669c79382c7a063298813e11be66bae68e32f..6fcb2cc615fa3f5d37d1a64866a02f78ff341981 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apache
 PKG_VERSION:=2.4.41
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_SOURCE_NAME:=httpd
 
 PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
@@ -268,6 +268,7 @@ CONFIGURE_ARGS+= \
 endif
 
 CONFIGURE_VARS += \
+       ac_cv_gettid=yes \
        ap_cv_void_ptr_lt_long=no
 
 define Build/Prepare