php7: fix build with QUILT 14894/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 25 Feb 2021 22:09:12 +0000 (19:09 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Fri, 26 Feb 2021 14:23:11 +0000 (11:23 -0300)
When building with QUILT, unlike the regular build, Build/Prepare does
not apply the patches.  So when buildconf is called with QUILT on, at
the end of Build/Prepare, it will not have the patched sources, and
build will fail.

To fix the problem, run buildconf in Build/Prepare only when QUILT is
off, and do it in Build/Configure otherwise.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
lang/php7/Makefile

index 0f49819f983fa4158ee4c67d25e3793709d0b842..96268e5644b0b3f079d24689c0ec9e1216e16279 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=7.4.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 PKG_LICENSE:=PHP-3.01
@@ -530,7 +530,12 @@ endef
 
 define Build/Prepare
        $(call Build/Prepare/Default)
-       ( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force )
+       $(if $(QUILT),,( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force ))
+endef
+
+define Build/Configure
+       $(if $(QUILT),( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force ))
+       $(call Build/Configure/Default)
 endef
 
 define Build/InstallDev