lftp: updated to 4.7.1 2593/head
authorRupan <fededim@gmail.com>
Tue, 12 Apr 2016 23:49:25 +0000 (01:49 +0200)
committerRupan <fededim@gmail.com>
Tue, 12 Apr 2016 23:49:25 +0000 (01:49 +0200)
davfs2: updated to 1.5.3 and reintroduced support for libssp

Signed-off-by: Federico Di Marco <fededim@gmail.com>
net/davfs2/Makefile
net/davfs2/patches/010-main_code_fix.patch
net/lftp/Makefile

index a8b3fd13864cdabd24bfb211a52f69183ab7382b..008dae73ab88f1c3c278920fb438a4fb6e290bcc 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=davfs2
-PKG_VERSION:=1.5.2
-PKG_RELEASE:=3
+PKG_VERSION:=1.5.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/davfs2/
-PKG_MD5SUM:=376bc9346454135cba78afacbcb23f86
+PKG_MD5SUM:=ecff993c7972bd92e23c138b71f042b1
 
 PKG_FIXUP:=gettext-version autoreconf
 
index aa36fdfaa734ff56c7f7b457e52c9a076d396d97..d91336d2734f9baf2426333773d94d0f5fb70557 100644 (file)
@@ -1,16 +1,3 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -32,8 +32,8 @@ mount_davfs_SOURCES = cache.c dav_coda.c
-         kernel_interface.h mount_davfs.h webdav.h
- umount_davfs_SOURCES = umount_davfs.c defaults.h
--AM_CFLAGS = -Wall -Werror=format-security \
--        -fstack-protector --param=ssp-buffer-size=4
-+AM_CFLAGS = -Wall -Werror=format-security 
-+#        -fstack-protector --param=ssp-buffer-size=4  -- removed ssp not supported in openwrt
- DEFS = -DPROGRAM_NAME=\"mount.davfs\" \
-        -DDAV_SYS_CONF_DIR=\"$(pkgsysconfdir)\" \
-        -DDAV_LOCALSTATE_DIR=\"$(dav_localstatedir)\" \
 --- a/src/cache.c
 +++ b/src/cache.c
 @@ -58,7 +58,7 @@
index 01ea998200cd1060b514cebc3322b165d41a525a..7a59c0511fa376c2551ea8e81a18f92779137ac4 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lftp
-PKG_VERSION:=4.6.2
+PKG_VERSION:=4.7.1
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://lftp.yar.ru/ftp \
                http://lftp.yar.ru/ftp/old \
                http://lftp.cybermirror.org \
                http://lftp.cybermirror.org/old
-PKG_MD5SUM:=487c064ee1bd732e5f95928e530435a8
+PKG_MD5SUM:=7dfb03c6544efeef633bc28ba7df8b77
 
 
 
@@ -61,6 +61,7 @@ CONFIGURE_ARGS += \
        --without-libidn \
        --without-libresolv \
        --with-openssl="$(STAGING_DIR)/usr" \
+       --with-zlib="$(STAGING_DIR)/usr" \
        --disable-static
 
 #CONFIGURE_VARS += \