redis: update to version 6.2.1 15057/head
authorJan Pavlinec <jan.pavlinec@nic.cz>
Mon, 8 Mar 2021 13:48:07 +0000 (14:48 +0100)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Mon, 8 Mar 2021 13:48:41 +0000 (14:48 +0100)
Changes:
-remove zmalloc patch which is part of release

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
libs/redis/Makefile
libs/redis/patches/030-fix-size_t-zmalloc.patch [deleted file]

index 41875887234eded35cf42827ced18e8702da2721..4ed494c4481e835441ed1064dd83e5ea990466e6 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=redis
-PKG_VERSION:=6.2.0
+PKG_VERSION:=6.2.1
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://download.redis.io/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=67d624c25d962bd68aff8812a135df85bad07556b8825f3bcd5b522a9932dbca
+PKG_HASH:=cd222505012cce20b25682fca931ec93bd21ae92cb4abfe742cf7b76aa907520
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=BSD-3-Clause
diff --git a/libs/redis/patches/030-fix-size_t-zmalloc.patch b/libs/redis/patches/030-fix-size_t-zmalloc.patch
deleted file mode 100644 (file)
index a0bfacb..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From dd885780d67f18f356a5652ab6d4f947ee035305 Mon Sep 17 00:00:00 2001
-From: Yossi Gottlieb <yossigo@gmail.com>
-Date: Tue, 23 Feb 2021 17:08:49 +0200
-Subject: [PATCH] Fix compile errors with no HAVE_MALLOC_SIZE. (#8533)
-
-Also adds a new daily CI test, relying on the fact that we don't use malloc_size() on alpine libmusl.
-
-Fixes #8531
----
- .github/workflows/daily.yml | 22 +++++++++++++++++++++-
- src/zmalloc.c               |  7 ++-----
- 2 files changed, 23 insertions(+), 6 deletions(-)
-
---- a/src/zmalloc.c
-+++ b/src/zmalloc.c
-@@ -32,6 +32,7 @@
- #include <stdlib.h>
- #include <stdint.h>
- #include <unistd.h>
-+#include <assert.h>
- /* This function provide us access to the original libc free(). This is useful
-  * for instance to free results obtained by backtrace_symbols(). We need
-@@ -49,18 +50,14 @@ void zlibc_free(void *ptr) {
- #ifdef HAVE_MALLOC_SIZE
- #define PREFIX_SIZE (0)
-+#define ASSERT_NO_SIZE_OVERFLOW(sz)
- #else
- #if defined(__sun) || defined(__sparc) || defined(__sparc__)
- #define PREFIX_SIZE (sizeof(long long))
- #else
- #define PREFIX_SIZE (sizeof(size_t))
- #endif
--#endif
--
--#if PREFIX_SIZE > 0
- #define ASSERT_NO_SIZE_OVERFLOW(sz) assert((sz) + PREFIX_SIZE > (sz))
--#else
--#define ASSERT_NO_SIZE_OVERFLOW(sz)
- #endif
- /* Explicitly override malloc/free etc when using tcmalloc. */