Added wccpd a Web Cache Coordination Protocol daemon
authorFlorian Fainelli <florian@openwrt.org>
Wed, 14 Dec 2005 12:01:36 +0000 (12:01 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 14 Dec 2005 12:01:36 +0000 (12:01 +0000)
SVN-Revision: 2668

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/wccpd/Config.in [new file with mode: 0755]
openwrt/package/wccpd/Makefile [new file with mode: 0755]
openwrt/package/wccpd/ipkg/wccpd.control [new file with mode: 0755]

index 4342107e52d8d0b706fd5c065d5d4f07b2efe29b..51e3e5ec07d4e719f426486041438a81307ee4e2 100644 (file)
@@ -136,6 +136,7 @@ source "package/vpnc/Config.in"
 source "package/vrrpd/Config.in"
 source "package/vsftpd/Config.in"
 source "package/vtun/Config.in"
+source "package/wccpd/Config.in"
 source "package/wificonf/Config.in"
 source "package/wifidog/Config.in"
 source "package/wireless-tools/Config.in"
index e273949fdab759934fd7c75382ee9083f5c4a371..b4ad107431ed9a0938216910bee39c321e5ddedf 100644 (file)
@@ -212,6 +212,7 @@ package-$(BR2_PACKAGE_VPNC) += vpnc
 package-$(BR2_PACKGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
+package-$(BR2_PACKAGE_WCCPD) += wccpd
 package-$(BR2_PACKAGE_WIFICONF) += wificonf
 package-$(BR2_PACKAGE_WIFIDOG) += wifidog
 package-$(BR2_PACKAGE_WIVIZ) += wiviz
diff --git a/openwrt/package/wccpd/Config.in b/openwrt/package/wccpd/Config.in
new file mode 100755 (executable)
index 0000000..33b35ec
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_WCCPD
+       prompt "wccpd............................. a Web Cache Coordination daemon"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+               wccpd is a WCCP (Web Cache Coordination Protocol) server daemon
+               It allows a router (running Linux) to redirect web traffic to a
+               group of Squid servers using WCCP as the monitoring/controling 
+               protocol.
diff --git a/openwrt/package/wccpd/Makefile b/openwrt/package/wccpd/Makefile
new file mode 100755 (executable)
index 0000000..318a074
--- /dev/null
@@ -0,0 +1,51 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wccpd
+PKG_VERSION:=0.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
+PKG_SOURCE_URL:=@SF/wccpd
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WCCPD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS)" \
+               ac_cv_func_setpgrp_void=yes \
+                ./configure \
+                --target=$(GNU_TARGET_NAME) \
+                --host=$(GNU_TARGET_NAME) \
+                --build=$(GNU_HOST_NAME) \
+                --prefix=/usr \
+                --exec-prefix=/usr \
+                --bindir=/usr/bin \
+                --sbindir=/usr/sbin \
+                --libexecdir=/usr/lib \
+                --sysconfdir=/etc \
+                --datadir=/usr/share \
+                --localstatedir=/var \
+                --mandir=/usr/man \
+                               --mandir=/usr/man \
+                --infodir=/usr/info \
+                --program-prefix="" \
+                               --with-gnu-ld \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       touch $@
+
+$(IPKG_WCCPD):
+       mkdir -p $(IDIR_WCCPD)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_WCCPD)/
+       $(RSTRIP) $(IDIR_WCCPD)
+       $(IPKG_BUILD) $(IDIR_WCCPD) $(PACKAGE_DIR)
diff --git a/openwrt/package/wccpd/ipkg/wccpd.control b/openwrt/package/wccpd/ipkg/wccpd.control
new file mode 100755 (executable)
index 0000000..136051d
--- /dev/null
@@ -0,0 +1,5 @@
+Package: wccpd
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: wccpd is a WCCP (Web Cache Coordination Protocol) server daemon.