vim: fix compile with BUILD_NLS 14905/head
authorRosen Penev <rosenp@gmail.com>
Fri, 26 Feb 2021 03:47:00 +0000 (19:47 -0800)
committerRosen Penev <rosenp@gmail.com>
Sat, 27 Feb 2021 09:40:26 +0000 (01:40 -0800)
Avoids having to use msgfmt, which happens to be broken with gettext-full.

msgfmt is used for the desktop gvim application, which is not used here.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/vim/Makefile
utils/vim/patches/010-no-msgfmt.patch [new file with mode: 0644]

index adc3751a7f4b47eac8ad35eb852dce8e709cbc34..da2e376304a8c046529b15a328205a9ea8d62957 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vim
 PKG_VERSION:=8.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 VIMVER:=82
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/utils/vim/patches/010-no-msgfmt.patch b/utils/vim/patches/010-no-msgfmt.patch
new file mode 100644 (file)
index 0000000..82e19bb
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/po/Makefile
++++ b/src/po/Makefile
+@@ -32,7 +32,7 @@ MSGMERGE = OLD_PO_FILE_INPUT=yes OLD_PO_
+       $(VIM) -u NONE -e -X -S check.vim -c "if error == 0 | q | endif" -c cq $<
+       touch $@
+-all: $(MOFILES) $(MOCONVERTED) $(MSGFMT_DESKTOP)
++all: $(MOFILES) $(MOCONVERTED)
+ check: $(CHECKFILES)