[packages] collectd: fix olsrd plugin statistics. Recent olsr-mod-txtinfo versions...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 5 Dec 2011 13:54:46 +0000 (13:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 5 Dec 2011 13:54:46 +0000 (13:54 +0000)
SVN-Revision: 29435

utils/collectd/Makefile
utils/collectd/patches/400-fix-olsrd-get-all.patch [new file with mode: 0644]

index 0e418ef50c548728bb6a409e1328019045612cc2..2d9afd4253a6b59f5488a2389b0cf014897e9a22 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.10.2
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
diff --git a/utils/collectd/patches/400-fix-olsrd-get-all.patch b/utils/collectd/patches/400-fix-olsrd-get-all.patch
new file mode 100644 (file)
index 0000000..b49a0e7
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/olsrd.c
++++ b/src/olsrd.c
+@@ -653,7 +653,7 @@ static int olsrd_read (void) /* {{{ */
+   if (fh == NULL)
+     return (-1);
+-  fputs ("\r\n", fh);
++  fputs ("/all \r\n", fh);
+   fflush (fh);
+   while (fgets (buffer, sizeof (buffer), fh) != NULL)