libtiff: don't include dev shared lib symlinks in package, bump release number
authorNicolas Thill <nico@openwrt.org>
Thu, 9 Jul 2009 13:22:50 +0000 (13:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 9 Jul 2009 13:22:50 +0000 (13:22 +0000)
SVN-Revision: 16750

libs/tiff/Makefile

index e238af56b4758de06416e411c372eb9ffc8f7c97..466720dac2720add52665a46e999056913be3067 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tiff
 PKG_VERSION:=3.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtiff.maptools.org/dl/
@@ -34,13 +34,13 @@ CONFIGURE_ARGS += --without-x
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib,include}
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
 endef
 
 define Package/libtiff/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libtiff))