[packages] ngrep: use PKG_INSTALL, install in /usr/bin instead of /usr/sbin, cleanup...
authorNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 11:58:59 +0000 (11:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 11:58:59 +0000 (11:58 +0000)
SVN-Revision: 22470

net/ngrep/Makefile

index 5321f0412907ee603283266f7223dffb7d5666fd..a516b43a2bc534382b08ae20062423c3220bf7f6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ngrep
 PKG_VERSION:=1.45
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ngrep
 PKG_MD5SUM:=bc8150331601f3b869549c94866b4f1c
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ngrep
@@ -34,27 +36,18 @@ define Package/ngrep/description
        like tcpdump and snoop.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-pcap-includes=$(STAGING_DIR)/usr/include \
-               --enable-pcre \
-               --with-pcre=$(STAGING_DIR)/usr \
-               --disable-dropprivs \
-               ,\
-               LDFLAGS="$(TARGET_LDFLAGS) -lpcre" \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --with-pcap-includes=$(STAGING_DIR)/usr/include \
+       --enable-pcre \
+       --with-pcre=$(STAGING_DIR)/usr \
+       --disable-dropprivs \
 
-define Build/Compile   
-       $(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all \
-       )
-endef
+CONFIGURE_VARS+= \
+       LDFLAGS="$(TARGET_LDFLAGS) -lpcre" \
 
 define Package/ngrep/install   
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ngrep $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ngrep))