package-ply: use given path instead of copying directly into staging_dir 1956/head
authorJeffery To <jeffery.to@gmail.com>
Mon, 16 Nov 2015 11:52:40 +0000 (19:52 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 16 Nov 2015 11:52:40 +0000 (19:52 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python-ply/Makefile

index 3e8792c806f7329b71d37b0d09fb0592dca9e053..ed3fb833d5a53a0fec19b418a7f5232667068a65 100644 (file)
@@ -43,10 +43,10 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(PYTHON_LIB_DIR)/site-packages
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
                $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-               $(PYTHON_LIB_DIR)/site-packages
+               $(1)$(PYTHON_PKG_DIR)
 endef
 
 $(eval $(call PyPackage,python-ply))