logrotate: remove selinux support 13158/head
authorRosen Penev <rosenp@gmail.com>
Tue, 18 Aug 2020 05:49:06 +0000 (22:49 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 18 Aug 2020 07:25:06 +0000 (00:25 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/logrotate/Makefile

index 46c415319c5cf6303b94cf12ccacf57ca0edea11..b4aee5bb1387a172fd10388d2c9ec5c2d418887b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=logrotate
 PKG_VERSION:=3.16.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/logrotate/logrotate/releases/download/$(PKG_VERSION)
@@ -51,7 +51,9 @@ define Package/logrotate/conffiles
 /etc/logrotate.conf
 endef
 
-CONFIGURE_ARGS += $(if $(CONFIG_LOGROTATE_ACL),--with,--without)-acl
+CONFIGURE_ARGS += \
+       $(if $(CONFIG_LOGROTATE_ACL),--with,--without)-acl \
+       --without-selinux
 
 define Build/Compile
        $(call Build/Compile/Default, \