[packages] pciutils: update to 3.1.5, remove the gzip-only mirror, switch to using...
authorStephen Walker <stephendwalker@gmail.com>
Thu, 21 Jan 2010 08:51:15 +0000 (08:51 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Thu, 21 Jan 2010 08:51:15 +0000 (08:51 +0000)
SVN-Revision: 19252

utils/pciutils/Makefile
utils/pciutils/patches/101-no-strip.patch [new file with mode: 0644]
utils/pciutils/patches/102-zcat-pciids.patch [new file with mode: 0644]

index 7db4f0c99f6328c50b563bc5c0015d56a4481641..db7cd308ac2ae63f9acc402e3de47dbe2d192885 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=3.1.4
+PKG_VERSION:=3.1.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils \
-       ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=b38142c61c52f42d19540a0fcb11050a
+PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
+PKG_MD5SUM:=7ccf8ae2353033158652bdca4e4aad0a
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,6 +24,7 @@ define Package/pciutils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
   URL:=http://mj.ucw.cz/pciutils.shtml
+  DEPENDS:=+zlib
 endef
 
 define Package/pciutils/description
@@ -32,15 +34,14 @@ endef
 
 define Package/pciutils/postinst
 #!/bin/sh
-(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids.sh)
-exit 0
+$${IPKG_INSTROOT}/usr/sbin/update-pciids
 endef
 
 MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       IDSDIR="/usr/share" \
+       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       PREFIX="/usr" \
        HOST="$(GNU_TARGET_NAME)" \
-       ZLIB="no" \
+       ZLIB="yes" \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
@@ -52,9 +53,9 @@ endef
 
 define Package/pciutils/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{lspci,setpci,update-pciids} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/pci.ids.gz $(1)/usr/share/
 endef
 
 $(eval $(call BuildPackage,pciutils))
diff --git a/utils/pciutils/patches/101-no-strip.patch b/utils/pciutils/patches/101-no-strip.patch
new file mode 100644 (file)
index 0000000..032118c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -101,7 +101,7 @@ distclean: clean
+ install: all
+ # -c is ignored on Linux, but required on FreeBSD
+       $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7
+-      $(INSTALL) -c -m 755 $(STRIP) lspci setpci $(DESTDIR)$(SBINDIR)
++      $(INSTALL) -c -m 755 lspci setpci $(DESTDIR)$(SBINDIR)
+       $(INSTALL) -c -m 755 update-pciids $(DESTDIR)$(SBINDIR)
+       $(INSTALL) -c -m 644 $(PCI_IDS) $(DESTDIR)$(IDSDIR)
+       $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
diff --git a/utils/pciutils/patches/102-zcat-pciids.patch b/utils/pciutils/patches/102-zcat-pciids.patch
new file mode 100644 (file)
index 0000000..c485097
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/update-pciids.sh
++++ b/update-pciids.sh
+@@ -6,9 +6,8 @@ set -e
+ SRC="http://pciids.sourceforge.net/v2.2/pci.ids"
+ DEST=pci.ids
+ PCI_COMPRESSED_IDS=
+-GREP=grep
+-# if pci.ids is read-only (because the filesystem is read-only),
++# if pci.ids.gz is read-only (because the filesystem is read-only),
+ # then just skip this whole process.
+ if ! touch ${DEST} >/dev/null 2>&1 ; then
+       ${quiet} || echo "${DEST} is read-only, exiting." 1>&2
+@@ -18,7 +17,6 @@ fi
+ if [ -n "$PCI_COMPRESSED_IDS" ] ; then
+       DECOMP="cat"
+       SRC="$SRC.gz"
+-      GREP=zgrep
+ elif which bzip2 >/dev/null 2>&1 ; then
+       DECOMP="bzip2 -d"
+       SRC="$SRC.bz2"
+@@ -53,7 +51,7 @@ if ! $DECOMP <$DEST.new >$DEST.neww ; th
+       exit 1
+ fi
+-if ! $GREP >/dev/null "^C " $DEST.neww ; then
++if ! zcat $DEST.neww | grep >/dev/null "^C " ; then
+       echo >&2 "update-pciids: missing class info, probably truncated file"
+       exit 1
+ fi