nut: fix compilation with GCC11 16072/head
authorRosen Penev <rosenp@gmail.com>
Wed, 7 Jul 2021 03:20:29 +0000 (20:20 -0700)
committerRosen Penev <rosenp@gmail.com>
Wed, 7 Jul 2021 21:52:31 +0000 (14:52 -0700)
nut is a C++98 project which does not compile with GCC11's default of
C++17.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/nut/Makefile

index c26c5832c24cab7126e1be912e7151a17ef4e8a8..0cc4afc32032b8ece2dc161f77566e46fb57894c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nut
 PKG_VERSION:=2.7.4
-PKG_RELEASE:=22
+PKG_RELEASE:=23
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.networkupstools.org/source/2.7/
@@ -542,6 +542,8 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_PACKAGE_nut-web-cgi),--with-gd-includes="`pkg-config --cflags gdlib`") \
        $(if $(CONFIG_PACKAGE_nut-web-cgi),--with-gd-libs="`pkg-config --libs gdlib`")
 
+TARGET_CXXFLAGS += -std=c++98
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so* $(1)/usr/lib/