gst1-plugins-bad: Disable debug and other fixes
authorRosen Penev <rosenp@gmail.com>
Mon, 18 Mar 2019 02:31:34 +0000 (19:31 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 18 Mar 2019 04:12:42 +0000 (21:12 -0700)
Added PKG_BUILD_PARALLEL for faster compilation.

Removed rpath hack that is no longer needed.

Added PIC as is typically the case with these.

Remove obsolete patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
multimedia/gst1-plugins-bad/Makefile
multimedia/gst1-plugins-bad/patches/002-no-tests.patch [deleted file]

index fcc3e15610a11b49d106ceb7dfd5cd27a2e9c08f..b3044992ae0941b44e300dd5e29f05aa50372515 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-bad
 PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
                Ted Hess <thess@kitschensync.net>
@@ -23,6 +23,7 @@ PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
 PKG_HASH:=eafbb705190ca6dbf0e5dfbe1bc3d0f217fbc2a828037b5ede12d3611b9f9bd7
 
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -96,9 +97,16 @@ endef
 GST_VERSION:=1.0
 
 CONFIGURE_ARGS += \
+       --disable-Bsymbolic \
        --disable-debug \
        --disable-examples \
-       --disable-nls   \
+       --disable-fatal-warnings \
+       --disable-glib-asserts \
+       --disable-gobject-cast-checks \
+       --disable-gtk-doc-html \
+       --disable-introspection \
+       --disable-valgrind \
+       --disable-rpath \
        \
        --disable-directsound \
        --disable-directdraw \
@@ -147,17 +155,11 @@ CONFIGURE_ARGS += \
        --disable-zbar \
        --disable-srtp \
        \
+       --without-html-dir \
        --without-libiconv-prefix \
        --without-libintl-prefix \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
-       --without-x \
-
-TARGET_CFLAGS+= -std=gnu99
-
-EXTRA_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       $(if $(ICONV_FULL),-liconv) \
-
+       --with-pic
 
 define Package/gst1-plugins-bad/install
        /bin/true
diff --git a/multimedia/gst1-plugins-bad/patches/002-no-tests.patch b/multimedia/gst1-plugins-bad/patches/002-no-tests.patch
deleted file mode 100644 (file)
index f5ee28e..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -u --recursive gst-plugins-bad-1.15.2-vanilla/configure.ac gst-plugins-bad-1.15.2/configure.ac
---- gst-plugins-bad-1.15.2-vanilla/configure.ac        2019-03-16 19:01:31.866656521 -0400
-+++ gst-plugins-bad-1.15.2/configure.ac        2019-03-16 19:02:41.864809432 -0400
-@@ -2609,23 +2609,6 @@
- sys/wasapi/Makefile
- sys/winks/Makefile
- sys/winscreencap/Makefile
--tests/Makefile
--tests/check/Makefile
--tests/files/Makefile
--tests/examples/Makefile
--tests/examples/avsamplesink/Makefile
--tests/examples/camerabin2/Makefile
--tests/examples/codecparsers/Makefile
--tests/examples/directfb/Makefile
--tests/examples/audiomixmatrix/Makefile
--tests/examples/ipcpipeline/Makefile
--tests/examples/mpegts/Makefile
--tests/examples/mxf/Makefile
--tests/examples/opencv/Makefile
--tests/examples/uvch264/Makefile
--tests/examples/waylandsink/Makefile
--tests/examples/webrtc/Makefile
--tests/icles/Makefile
- ext/voamrwbenc/Makefile
- ext/voaacenc/Makefile
- ext/assrender/Makefile
-diff -u --recursive gst-plugins-bad-1.15.2-vanilla/Makefile.am gst-plugins-bad-1.15.2/Makefile.am
---- gst-plugins-bad-1.15.2-vanilla/Makefile.am 2019-03-16 19:01:31.865656518 -0400
-+++ gst-plugins-bad-1.15.2/Makefile.am 2019-03-16 19:02:34.694793766 -0400
-@@ -2,11 +2,11 @@
- SUBDIRS = \
-       gst-libs gst sys ext pkgconfig \
--      m4 common docs tests tools
-+      m4 common docs tools
- DIST_SUBDIRS = \
-       gst gst-libs sys ext pkgconfig \
--      m4 common docs tests tools
-+      m4 common docs tools
- EXTRA_DIST = \
-       depcomp \