do not depend on external opencdk (not used) and libtasn1, use bundled version instea...
authorNicolas Thill <nico@openwrt.org>
Thu, 18 Aug 2005 08:18:15 +0000 (08:18 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 18 Aug 2005 08:18:15 +0000 (08:18 +0000)
SVN-Revision: 1695

openwrt/package/Makefile
openwrt/package/gnutls/Config.in
openwrt/package/gnutls/Makefile
openwrt/package/gnutls/ipkg/libgnutls.control

index 63cd737a83ed15e41af8c1d933333cb1f8758967..375b4a4e6371f1b9d42c8690581ef8b10b08743b 100644 (file)
@@ -41,7 +41,7 @@ package-$(BR2_PACKAGE_FUSE) += fuse
 package-$(BR2_PACKAGE_GDBSERVER) += gdbserver
 package-$(BR2_PACKAGE_GLIB) += glib
 package-$(BR2_PACKAGE_GMP) += gmp
-package-$(BR2_PACKAGE_GNUTLS) += gnutls
+package-$(BR2_COMPILE_GNUTLS) += gnutls
 package-$(BR2_PACKAGE_HASERL) += haserl
 package-$(BR2_PACKAGE_HOSTAPD) += hostapd
 package-$(BR2_PACKAGE_HOWL) += howl
index a3d72e4f6d604011229746eaf13ac3869ef3bf25..1468205143ca890e0975dcb93611772afe6fa6dd 100644 (file)
@@ -1,4 +1,4 @@
-config BR2_PACKAGE_GNUTLS
+config BR2_COMPILE_GNUTLS
        bool
        default n
        depends BR2_PACKAGE_LIBGNUTLS
@@ -7,10 +7,8 @@ config BR2_PACKAGE_LIBGNUTLS
        tristate "libgnutls - The GNU TLS library"
 #      default m if CONFIG_DEVEL
        default n
-       select BR2_PACKAGE_GNUTLS
+       select BR2_COMPILE_GNUTLS
        select BR2_PACKAGE_LIBGCRYPT
-       select BR2_PACKAGE_LIBOPENCDK
-       select BR2_PACKAGE_LIBTASN1
        help
         GnuTLS is a project that aims to develop a library which provides a 
         secure layer, over a reliable transport layer. Currently the GnuTLS 
index fdb3b13b0c948056e511908f6e0c5a8be8f73eaa..3e8a31ea99ab9fa17f663296333d3e86c258fca8 100644 (file)
@@ -35,7 +35,7 @@ $(PKG_BUILD_DIR)/.configured:
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -62,10 +62,9 @@ $(PKG_BUILD_DIR)/.configured:
                --disable-srp-authentication \
                --disable-anon-authentication \
                --disable-openpgp-authentication \
-               --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
-               --with-libopencdk-prefix="$(STAGING_DIR)/usr" \
-               --with-libtasn1-prefix="$(STAGING_DIR)/usr" \
-               --with-included-libcfg \
+               --with-included-opencdk=yes \
+               --with-included-libtasn1=yes \
+               --with-included-libcfg=yes \
                --without-zlib \
                --without-lzo \
        );
index 824a153e71d2bcf2cf6ab7d2cc05ae4ad6482e8a..edd3dd63e680bb2d42046a129c6414df8f3b0baf 100644 (file)
@@ -6,4 +6,4 @@ Architecture: [TBDL]
 Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/gnutls/
 Description: GNU TLS library
-Depends: libgcrypt, libopencdk, libtasn1
+Depends: libgcrypt