[package] fix libaxpian build failure (#6982)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:27 +0000 (11:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 29 Mar 2010 11:03:27 +0000 (11:03 +0000)
SVN-Revision: 20577

libs/libxapian/Makefile
libs/libxapian/patches/001-missing_includes.patch [new file with mode: 0644]
libs/libxapian/patches/002-elif_else_replacement.patch [new file with mode: 0644]
libs/libxapian/patches/003-no_docs_tests.patch [new file with mode: 0644]

index 784e27811a8e64e1be3005fe3ef2cb267838827b..82b3cecd28271ad454cd301a4e7c9352fc11c916 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xapian-core
 PKG_VERSION:=1.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://oligarchy.co.uk/xapian/$(PKG_VERSION)
diff --git a/libs/libxapian/patches/001-missing_includes.patch b/libs/libxapian/patches/001-missing_includes.patch
new file mode 100644 (file)
index 0000000..67f19fe
--- /dev/null
@@ -0,0 +1,63 @@
+diff -urN xapian-core-1.0.7/backends/flint/flint_version.cc xapian-core-1.0.7.new/backends/flint/flint_version.cc
+--- xapian-core-1.0.7/backends/flint/flint_version.cc  2008-07-16 06:42:34.000000000 +0200
++++ xapian-core-1.0.7.new/backends/flint/flint_version.cc      2010-03-29 09:59:58.000000000 +0200
+@@ -19,6 +19,7 @@
+  */
+ #include <config.h>
++#include <stdio.h>
+ #include "safeerrno.h"
+diff -urN xapian-core-1.0.7/bin/quartzdump.cc xapian-core-1.0.7.new/bin/quartzdump.cc
+--- xapian-core-1.0.7/bin/quartzdump.cc        2008-07-16 06:42:28.000000000 +0200
++++ xapian-core-1.0.7.new/bin/quartzdump.cc    2010-03-29 10:18:26.000000000 +0200
+@@ -29,6 +29,7 @@
+ #include <vector>
+ #include <string>
+ #include <ctype.h>
++#include <stdio.h>
+ #include "autoptr.h"
+ #include "gnu_getopt.h"
+--- xapian-core-1.0.7/bin/xapian-progsrv.cc    2008-07-16 06:42:28.000000000 +0200
++++ xapian-core-1.0.7.new/bin/xapian-progsrv.cc        2010-03-29 10:31:16.000000000 +0200
+@@ -19,6 +19,7 @@
+  */
+ #include <config.h>
++#include <stdio.h>
+ #include "remoteserver.h"
+--- xapian-core-1.0.7/bin/xapian-tcpsrv.cc     2008-07-16 06:42:28.000000000 +0200
++++ xapian-core-1.0.7.new/bin/xapian-tcpsrv.cc 2010-03-29 10:41:56.000000000 +0200
+@@ -21,6 +21,7 @@
+  */
+ #include <config.h>
++#include <stdio.h>
+ #include <stdlib.h>
+diff -urN xapian-core-1.0.7/examples/delve.cc xapian-core-1.0.7.new/examples/delve.cc
+--- xapian-core-1.0.7/examples/delve.cc        2008-07-16 06:42:35.000000000 +0200
++++ xapian-core-1.0.7.new/examples/delve.cc    2010-03-29 11:14:26.000000000 +0200
+@@ -21,6 +21,7 @@
+  */
+ #include <config.h>
++#include <stdio.h>
+ #include <xapian.h>
+--- xapian-core-1.0.7/examples/quest.cc        2008-07-16 06:42:35.000000000 +0200
++++ xapian-core-1.0.7.new/examples/quest.cc    2010-03-29 11:33:03.000000000 +0200
+@@ -19,6 +19,7 @@
+  */
+ #include <config.h>
++#include <stdio.h>
+ #include <xapian.h>
diff --git a/libs/libxapian/patches/002-elif_else_replacement.patch b/libs/libxapian/patches/002-elif_else_replacement.patch
new file mode 100644 (file)
index 0000000..66938ac
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN xapian-core-1.0.7/common/serialise-double.cc xapian-core-1.0.7.new/common/serialise-double.cc
+--- xapian-core-1.0.7/common/serialise-double.cc       2008-07-16 06:42:30.000000000 +0200
++++ xapian-core-1.0.7.new/common/serialise-double.cc   2010-03-29 10:07:02.000000000 +0200
+@@ -56,7 +56,7 @@
+ # define MAX_MANTISSA_BYTES ((DBL_MANT_DIG + 1 + 1) / 2)
+ # define MAX_EXP ((DBL_MAX_EXP + 1) / 2)
+ # define MAX_MANTISSA (1 << ((DBL_MAX_EXP & 1) * 4))
+-#elif
++#else
+ # error FLT_RADIX is a value not currently handled (not 2 or 16)
+ // # define MAX_MANTISSA_BYTES (sizeof(double) + 1)
+ #endif
diff --git a/libs/libxapian/patches/003-no_docs_tests.patch b/libs/libxapian/patches/003-no_docs_tests.patch
new file mode 100644 (file)
index 0000000..5971115
--- /dev/null
@@ -0,0 +1,22 @@
+--- xapian-core-1.0.7/Makefile.am      2008-07-16 06:42:35.000000000 +0200
++++ xapian-core-1.0.7.new/Makefile.am  2010-03-29 11:01:13.000000000 +0200
+@@ -14,7 +14,7 @@
+ endif
+ # Order is relevant: when building, tests must be after ".".
+-SUBDIRS = . docs tests
++SUBDIRS = .
+ noinst_HEADERS =
+ BUILT_SOURCES =
+--- xapian-core-1.0.7/Makefile.in      2008-07-16 06:46:51.000000000 +0200
++++ xapian-core-1.0.7.new/Makefile.in  2010-03-29 11:01:24.000000000 +0200
+@@ -847,7 +847,7 @@
+       $(am__append_1) $(am__append_25)
+ # Order is relevant: when building, tests must be after ".".
+-SUBDIRS = . docs tests
++SUBDIRS = .
+ noinst_HEADERS = api/maptermlist.h api/editdistance.h $(am__append_9) \
+       $(am__append_12) backends/multi/multi_postlist.h \
+       backends/multi/multi_termlist.h $(am__append_15) \