Revert "zoneinfo: Updated to the latest release"
authorHannu Nyman <hannu.nyman@iki.fi>
Mon, 19 Oct 2020 17:32:58 +0000 (20:32 +0300)
committerHannu Nyman <hannu.nyman@iki.fi>
Mon, 19 Oct 2020 17:32:58 +0000 (20:32 +0300)
This reverts commit 1f5f599d0ea434820e06fd540ecbc9c7f15399b4
that bumped the zoneinfo version from 2020a to 2020b.

Apparently some libc are incompatible with the data format in 2020b.
At least our default libc, musl, fails to parse timezones from the
compiled 2020b zoneinfo files.

Release notes mention that deprecated "posixrules" feature is now
omitted from the default build. Possibly musl uses it?

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
utils/zoneinfo/Makefile

index 3e6e48d15448681d5fed0d6be8aa5d599cfd726d..608b1f0d2e5ed9f0e79d8af08da281493d80a1ca 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zoneinfo
-PKG_VERSION:=2020b
+PKG_VERSION:=2020a
 PKG_RELEASE:=1
 
 #As i couldn't find real license used "Public Domain"
@@ -19,14 +19,14 @@ PKG_LICENSE:=Public Domain
 PKG_SOURCE:=tzdata$(PKG_VERSION).tar.gz
 PKG_SOURCE_CODE:=tzcode$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.iana.org/time-zones/repository/releases
-PKG_HASH:=9b053f951d245ce89d850b96ee4711d82d833559b1fc96ba19f90bc4d745e809
+PKG_HASH:=547161eca24d344e0b5f96aff6a76b454da295dc14ed4ca50c2355043fb899a2
 
 include $(INCLUDE_DIR)/package.mk
 
 define Download/tzcode
    FILE=$(PKG_SOURCE_CODE)
    URL=$(PKG_SOURCE_URL)
-   HASH:=47eff8944de4a64f7629b851e4a32338ab12c9b73edd62063795167ff1fe43da
+   HASH:=7d2af7120ee03df71fbca24031ccaf42404752e639196fe93c79a41b38a6d669
 endef
 
 $(eval $(call Download,tzcode))