ipq40xx: use DEVICE_VARIANT for Unielec U4019 flash size
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 21 Oct 2019 11:20:15 +0000 (13:20 +0200)
committerJohn Crispin <john@phrozen.org>
Sun, 27 Oct 2019 13:03:21 +0000 (14:03 +0100)
If flash size is used as part of a device's title, it should be
specified as DEVICE_VARIANT like for the other devices so far.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ipq40xx/image/Makefile

index 5b460d1c1fbda10b0bf2f97d8bf02f401d07f2c5..ed46bca6490b4e1fda2718720fb9bcf8975ce9a0 100644 (file)
@@ -417,7 +417,8 @@ TARGET_DEVICES += qxwlan_e2600ac-c2
 define Device/unielec_u4019-32m
        $(call Device/FitImage)
        DEVICE_VENDOR := Unielec
-       DEVICE_MODEL := U4019 (32M)
+       DEVICE_MODEL := U4019
+       DEVICE_VARIANT := 32M
        BOARD_NAME := u4019-32m
        DEVICE_DTS := qcom-ipq4019-unielec-u4019-32m
        KERNEL_SIZE := 4096k