libSM, libXpm: dependency fixes
authorMichael Büsch <mb@bu3sch.de>
Thu, 27 Jan 2011 17:30:51 +0000 (17:30 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 27 Jan 2011 17:30:51 +0000 (17:30 +0000)
SVN-Revision: 25155

Xorg/xorg/lib/libSM/Makefile
Xorg/xorg/lib/libXpm/Makefile

index bffc858a0ba980cc90426c7405565067a70b6bb2..08dbd64c141cba7a679a03ddbb1006520e6a402d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_BASE_NAME:=libSM
 PKG_NAME:=libSM
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=1.1.1
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/lib/
@@ -27,7 +27,7 @@ define Package/libSM
   SECTION:=xorg-libraries
   CATEGORY:=Xorg
   SUBMENU:=libraries
-  DEPENDS:=+libICE
+  DEPENDS:=+libICE +libuuid
   TITLE:=libSM
   URL:=http://xorg.freedesktop.org/
 endef
index c72be242743e62a63d29a817970bf2b60041edde..05186d13025832cdcab6d81da0c36be15e878e90 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libXpm
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=3.5.8
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/lib/
@@ -26,11 +26,13 @@ define Package/libXpm
   SECTION:=xorg-libraries
   CATEGORY:=Xorg
   SUBMENU:=libraries
-  DEPENDS:=+libX11 +libXt +libXext
+  DEPENDS:=+libX11 +libXt +libXext +libSM
   TITLE:=libXpm
   URL:=http://xorg.freedesktop.org/
 endef
 
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11}
        $(CP) \