coreutils: move alternatives to /usr/libexec
authorHuangbin Zhan <zhanhb88@gmail.com>
Fri, 12 Jun 2020 12:35:04 +0000 (20:35 +0800)
committerHuangbin Zhan <zhanhb88@gmail.com>
Fri, 12 Jun 2020 12:35:04 +0000 (20:35 +0800)
Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
utils/coreutils/Makefile

index 62cb51fadfc67b6db444d52e3a3cbed08e9a0310..157a2496f1115bc449d430632a431ddee295b2ea 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coreutils
 PKG_VERSION:=8.32
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/coreutils
@@ -56,9 +56,9 @@ DIR_OTHERS := \
        base32 b2sum basenc csplit dir dircolors fmt join numfmt pathchk pinky  \
        pr ptx sha224sum sha384sum stdbuf tsort vdir
 
-$(eval $(foreach a,$(DIR_BIN),ALTS_$(a):=300:/bin/$(a):/usr/bin/gnu-$(a)$(newline)))
-$(eval $(foreach a,$(DIR_USR_BIN),ALTS_$(a):=300:/usr/bin/$(a):/usr/bin/gnu-$(a)$(newline)))
-$(eval $(foreach a,$(DIR_USR_SBIN),ALTS_$(a):=300:/usr/sbin/$(a):/usr/bin/gnu-$(a)$(newline)))
+$(eval $(foreach a,$(DIR_BIN),ALTS_$(a):=300:/bin/$(a):/usr/libexec/$(a)-coreutils$(newline)))
+$(eval $(foreach a,$(DIR_USR_BIN),ALTS_$(a):=300:/usr/bin/$(a):/usr/libexec/$(a)-coreutils$(newline)))
+$(eval $(foreach a,$(DIR_USR_SBIN),ALTS_$(a):=300:/usr/sbin/$(a):/usr/libexec/$(a)-coreutils$(newline)))
 
 DEPENDS_sort = +libpthread
 DEPENDS_timeout = +librt
@@ -137,8 +137,8 @@ endef
 
 define BuildPlugin
   define Package/$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $$(1)/usr/bin/$(if $(ALTS_$(2)),gnu-$(2),$(2))
+       $(INSTALL_DIR) $$(1)/usr/$(if $(ALTS_$(2)),libexec,bin)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $$(1)/usr/$(if $(ALTS_$(2)),libexec/$(2)-coreutils,bin/$(2))
        $(foreach f,$(FILES_$(2)),
                $(INSTALL_DIR) $$(1)/$(dir $(f))
                $(INSTALL_BIN) $(PKG_INSTALL_DIR)/$(f) $$(1)/$(f)