Add the gpio_keys input module to menuconfig
authorGabor Juhos <juhosg@openwrt.org>
Mon, 6 Jul 2009 16:10:20 +0000 (16:10 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 6 Jul 2009 16:10:20 +0000 (16:10 +0000)
Signed-off-by: Ferenc Wagner <wferi@niif.hu>
SVN-Revision: 16716

package/kernel/modules/other.mk

index 74905e1234b8481a89e3fa88a56c52f5e6f50aa9..fdadfa10e139a0dc281d56a6128233647da5905b 100644 (file)
@@ -674,6 +674,23 @@ endef
 $(eval $(call KernelPackage,input-polldev))
 
 
+define KernelPackage/input-gpio-keys
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=GPIO key support
+  DEPENDS:= @GPIO_SUPPORT +kmod-input-core
+  KCONFIG:=CONFIG_KEYBOARD_GPIO
+  FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
+endef
+
+define KernelPackage/input-gpio-keys/description
+ This driver implements support for buttons connected
+ to GPIO pins of various CPUs (and some other chips).
+endef
+
+$(eval $(call KernelPackage,input-gpio-keys))
+
+
 define KernelPackage/input-gpio-buttons
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Polled GPIO buttons input device