Add Makefile check for PAuth and AArch64
authorJohn Tsichritzis <john.tsichritzis@arm.com>
Tue, 7 May 2019 13:09:09 +0000 (14:09 +0100)
committerJohn Tsichritzis <john.tsichritzis@arm.com>
Thu, 9 May 2019 10:31:14 +0000 (11:31 +0100)
Pointer authentication is supported only in AArch64. A relevant check is
added for that in the Makefile.

Change-Id: I021ba65a9bd5764fd33292bee42617015e04a870
Signed-off-by: John Tsichritzis <john.tsichritzis@arm.com>
Makefile

index 41a64f93eba346e5516d17978eff8aa93d9c4062..16b4ccc4277685044b6049380de6b4fb837076ae 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -454,14 +454,20 @@ endif
 # registers associated to it are also saved and restored. Not doing it would
 # leak the value of the key used by EL3 to EL1 and S-EL1.
 ifeq ($(ENABLE_PAUTH),1)
-    ifeq ($(CTX_INCLUDE_PAUTH_REGS),0)
+    ifneq ($(ARCH),aarch64)
+        $(error ENABLE_PAUTH=1 requires AArch64)
+    else ifeq ($(CTX_INCLUDE_PAUTH_REGS),0)
         $(error ENABLE_PAUTH=1 requires CTX_INCLUDE_PAUTH_REGS=1)
     else
         $(info ENABLE_PAUTH and CTX_INCLUDE_PAUTH_REGS are experimental features)
     endif
 else
     ifeq ($(CTX_INCLUDE_PAUTH_REGS),1)
-        $(info CTX_INCLUDE_PAUTH_REGS is an experimental feature)
+        ifneq ($(ARCH),aarch64)
+            $(error CTX_INCLUDE_PAUTH_REGS=1 requires AArch64)
+        else
+            $(info CTX_INCLUDE_PAUTH_REGS is an experimental feature)
+        endif
     endif
 endif