Add C++ bufgix patch from #2965, bump release number
authorFlorian Fainelli <florian@openwrt.org>
Thu, 3 Jan 2008 17:32:18 +0000 (17:32 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 3 Jan 2008 17:32:18 +0000 (17:32 +0000)
SVN-Revision: 10094

libs/cgilib/Makefile
libs/cgilib/patches/300-cpp_bugfix.patch [new file with mode: 0644]

index 3ac1f5f42f218c8feb55d430d529ffa940bbf057..9bd2d42c5c3a0d9cf9bb324ddbcb639148d40ff5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cgilib
 PKG_VERSION:=0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.infodrom.org/projects/cgilib/download
diff --git a/libs/cgilib/patches/300-cpp_bugfix.patch b/libs/cgilib/patches/300-cpp_bugfix.patch
new file mode 100644 (file)
index 0000000..48ff7de
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Nur cgilib-0.5.orig/cgi.h cgilib-0.5/cgi.h
+--- cgilib-0.5.orig/cgi.h      2008-01-03 18:02:08.000000000 +0100
++++ cgilib-0.5/cgi.h   2008-01-03 18:02:31.000000000 +0100
+@@ -20,6 +20,10 @@
+ #ifndef _CGI_H_
+ #define _CGI_H_
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ typedef struct var_s {
+       char    *name,
+               *value;
+@@ -112,4 +116,8 @@
+  */
+ void cgiFree (s_cgi *parms);
++#ifdef __cplusplus
++} /* end of extern "C" */
++#endif
++
+ #endif /* _CGI_H_ */