libdaq3: Enable NFQ DAQ
authorMichal Hrusecky <michal.hrusecky@turris.com>
Thu, 17 Feb 2022 19:13:46 +0000 (20:13 +0100)
committerRosen Penev <rosenp@gmail.com>
Fri, 18 Feb 2022 03:27:40 +0000 (19:27 -0800)
Enable support for DAQ module that uses NFQUEUE.

Signed-off-by: Michal Hrusecky <michal.hrusecky@turris.com>
libs/libdaq3/Makefile

index 3ee1c11df89ceb33554ef9920f4eb3c9e96648a8..887b0cf872e81798703e55fe646f23180e6959db 100644 (file)
@@ -31,7 +31,7 @@ define Package/libdaq3
   CATEGORY:=Libraries
   TITLE:=DAQ library
   URL:=$(PKG_SOURCE_URL)
-  DEPENDS:=+libdnet +libpcap +libstdcpp
+  DEPENDS:=+libdnet +libpcap +libstdcpp +libmnl +libnetfilter-queue
 endef
 
 define Package/libdaq3/description
@@ -40,7 +40,7 @@ endef
 
 CONFIGURE_ARGS+= \
        --disable-static \
-       --disable-nfq-module \
+       --enable-nfq-module \
        --with-dnet-includes="$(STAGING_DIR)/usr/include" \
        --with-dnet-libraries="$(STAGING_DIR)/usr/lib" \
        --with-libpcap-includes="$(STAGING_DIR)/usr/include" \