dump1090: Switch to MalcolmRobb's repo, add myself as maintainer, fix html files...
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 15 Jun 2014 17:36:35 +0000 (19:36 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 15 Jun 2014 17:36:35 +0000 (19:36 +0200)
utils/dump1090/Config.in [new file with mode: 0644]
utils/dump1090/Makefile
utils/dump1090/patches/100-html_dir.patch [new file with mode: 0644]

diff --git a/utils/dump1090/Config.in b/utils/dump1090/Config.in
new file mode 100644 (file)
index 0000000..cee0aa5
--- /dev/null
@@ -0,0 +1,20 @@
+config DUMP1090_DUMP
+       bool "dump1090"
+       depends on PACKAGE_dump1090
+       default y
+       help
+               dump1090 ModeS Receiver
+
+config DUMP1090_WWW
+       bool "website files"
+       depends on DUMP1090_DUMP
+       default y
+       help
+               HTML website files for showing planes
+
+config DUMP1090_VIEW
+       bool "view1090"
+       depends on PACKAGE_dump1090
+       default n
+       help
+               view1090 dump1090 Viewer
index 3289f2bf6ad5485b622e911d93b9bc9ead5ba582..f260163547d2e595316ff78cd85d1b193e742b62 100644 (file)
@@ -7,19 +7,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dump1090
-PKG_VERSION:=2013-02-04
+PKG_VERSION:=2014-06-15
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/antirez/dump1090.git
+PKG_SOURCE_URL:=git://github.com/MalcolmRobb/dump1090.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=ff0fe38722c768c7269afa733790a2b968ea3099
+PKG_SOURCE_VERSION:=6afdc9bd1b0462a1606a5539d44cd33c57b44f84
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 
 PKG_LICENSE:=BSD-3c
 
-PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dump1090
@@ -30,6 +29,9 @@ define Package/dump1090
   DEPENDS:=+libpthread +librtlsdr
 endef
 
+define Package/dump1090/config
+       source "$(SOURCE)/Config.in"
+endef
 
 define Package/dump1090/description
  Dump1090 is a Mode S decoder specifically designed for RTLSDR devices.
@@ -42,10 +44,17 @@ MAKE_FLAGS += \
 
 define Package/dump1090/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
 
+ifneq ($(CONFIG_DUMP1090_DUMP),)
+       $(CP) $(PKG_BUILD_DIR)/dump1090 $(1)/usr/bin
+ifneq ($(CONFIG_DUMP1090_WWW),)
        $(INSTALL_DIR) $(1)/usr/share/dump1090
-       $(CP) $(PKG_BUILD_DIR)/gmap.html $(1)/usr/share/dump1090
+       $(CP) $(PKG_BUILD_DIR)/public_html/* $(1)/usr/share/dump1090
+endif
+endif
+ifneq ($(CONFIG_DUMP1090_VIEW),)
+       $(CP) $(PKG_BUILD_DIR)/view1090 $(1)/usr/bin
+endif
 endef
 
 $(eval $(call BuildPackage,dump1090))
diff --git a/utils/dump1090/patches/100-html_dir.patch b/utils/dump1090/patches/100-html_dir.patch
new file mode 100644 (file)
index 0000000..8976057
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/dump1090.h
++++ b/dump1090.h
+@@ -178,7 +178,7 @@
+ #define MODES_NET_SNDBUF_MAX  (7)               
+ #ifndef HTMLPATH
+-#define HTMLPATH   "./public_html"      // default path for gmap.html etc
++#define HTMLPATH   "/usr/share/dump1090"      // default path for gmap.html etc
+ #endif
+ #define MODES_NOTUSED(V) ((void) V)