gnutls: optionally disable tpm support 3174/head
authorIan Pozella <Ian.Pozella@imgtec.com>
Thu, 1 Sep 2016 16:13:35 +0000 (17:13 +0100)
committerIan Pozella <Ian.Pozella@imgtec.com>
Thu, 15 Sep 2016 14:29:49 +0000 (15:29 +0100)
Add option that allows you to explicitly disable use of the tpm
otherwise if a tss stack such as trousers is found by gnutls build
system then it will use it which will cause a build failure when
PKCS11 support is not enabled.

Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com>
libs/gnutls/Config.in
libs/gnutls/Makefile

index fc3b31758ebedd1905195f4d350e6fe8ab576bf7..562d678928988bc58d3101407ce4e27c9e6b7083 100644 (file)
@@ -39,6 +39,11 @@ config GNUTLS_ANON
        bool "enable anonymous authentication support"
        default y
 
+config GNUTLS_TPM
+       bool "enable tpm support"
+       select GNUTLS_PKCS11
+       default n
+
 config GNUTLS_PKCS11
        bool "enable smart card (PKCS11) support"
        select GNUTLS_EXT_LIBTASN1
index 240cce1f231d534ebce7288e442d54de224c1a62..412f7a1a77089e8221f4b632b44586803bd9a6b9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
 PKG_VERSION:=3.5.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -35,6 +35,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_GNUTLS_PKCS11 \
        CONFIG_GNUTLS_PSK \
        CONFIG_GNUTLS_SRP \
+       CONFIG_GNUTLS_TPM \
        CONFIG_LIBNETTLE_MINI \
 
 include $(INCLUDE_DIR)/package.mk
@@ -161,6 +162,10 @@ ifneq ($(CONFIG_GNUTLS_OCSP),y)
 CONFIGURE_ARGS += --disable-ocsp
 endif
 
+ifneq ($(CONFIG_GNUTLS_TPM),y)
+CONFIGURE_ARGS += --without-tpm
+endif
+
 ifeq ($(CONFIG_GNUTLS_CRYPTODEV),y)
 CONFIGURE_ARGS += --enable-cryptodev
 endif
@@ -220,6 +225,11 @@ ifeq ($(CONFIG_GNUTLS_PKCS11),y)
                $(PKG_INSTALL_DIR)/usr/bin/p11tool \
                $(1)/usr/bin/
 endif
+ifeq ($(CONFIG_GNUTLS_TPM),y)
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/tpmtool \
+               $(1)/usr/bin/
+endif
 endef