Merge pull request #16745 from neheb/tinc2
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 29 Sep 2021 09:05:40 +0000 (12:05 +0300)
committerGitHub <noreply@github.com>
Wed, 29 Sep 2021 09:05:40 +0000 (12:05 +0300)
tinc: update to 1.1pre18

22 files changed:
.github/workflows/entrypoint.sh
admin/sudo/Makefile
devel/delve/Makefile
lang/php7/Makefile
lang/php8/Makefile
lang/python/python3/Config-python3-light.in
lang/python/python3/Makefile
libs/libarchive/Makefile
libs/libseccomp/Makefile
libs/libseccomp/patches/010-no-code-coverage.patch [new file with mode: 0644]
mail/mutt/Makefile
net/dnsdist/Makefile
net/dnsdist/patches/010-time_t-check.patch [deleted file]
net/dnsdist/patches/020-gcc11.patch [deleted file]
net/nlbwmon/Makefile
net/openssh/Makefile
net/pdns-recursor/patches/010-time_t-check.patch [deleted file]
net/pdns/patches/010-time_t-check.patch [deleted file]
utils/fontconfig/patches/001-revert-upstream-meson-commit.patch [new file with mode: 0644]
utils/rtty/Makefile
utils/rtty/files/rtty.config
utils/rtty/files/rtty.init

index d7d4ecd0eb542ae43306aec1b32eaeb84ee0ee7b..76041054736c8ed1ab14fe5781622681d3a8730b 100755 (executable)
@@ -26,7 +26,7 @@ for PKG in /ci/*.ipk; do
        if [ -f "$TEST_SCRIPT" ]; then
                echo "Use package specific test.sh"
                if sh "$TEST_SCRIPT" "$PKG_NAME" "$PKG_VERSION"; then
-                       echo "Test succesful"
+                       echo "Test successful"
                else
                        echo "Test failed"
                        exit 1
index 8facbdd872283d52d81a6c9e340446da90d91aaa..bc0c7d6e313c8e9bc5a2c91a2587530eb7409248 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sudo
-PKG_VERSION:=1.9.8p1
+PKG_VERSION:=1.9.8p2
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.sudo.ws/dist
-PKG_HASH:=0939ee24df7095a92e0ca4aa3bd53b2a10965a7b921d51a26ab70cdd24388d69
+PKG_HASH:=9e3b8b8da7def43b6e60c257abe80467205670fd0f7c081de1423c414b680f2d
 
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
 
index 54eb5b04539394b6299e2a3cce7fef749f066af3..f3c19e192d77cdd5f7d2ef34e23edb88b7050f15 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=delve
-PKG_VERSION:=1.7.1
+PKG_VERSION:=1.7.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/go-delve/delve/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=0734b86d48291749ba2537fa6c03e4c3451628f630055c877789e0346db8d67d
+PKG_HASH:=c2eb068d5677e114286b38f57f784b3792dbd2db06743bb57217611a092b31f2
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
index ed1566459d8857ee80eaa9249bc64bf3a7c2e738..d343986f2d52de94ad82d542fcb32bae1a48d672 100644 (file)
@@ -6,8 +6,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=7.4.23
-PKG_RELEASE:=2
+PKG_VERSION:=7.4.24
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 PKG_LICENSE:=PHP-3.01
@@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=cea52313fcffe56343bcd3c66dbb23cd5507dc559cc2e3547cf8f5452e88a05d
+PKG_HASH:=ff7658ee2f6d8af05b48c21146af5f502e121def4e76e862df5ec9fa06e98734
 
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
@@ -175,6 +175,10 @@ CONFIGURE_ARGS+= \
        --with-external-pcre \
        --with-zlib="$(STAGING_DIR)/usr"
 
+ifeq ($(CONFIG_LIBC_USE_GLIBC),y)
+TARGET_LDFLAGS += -ldl
+endif
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-bcmath),)
   CONFIGURE_ARGS+= --enable-bcmath=shared
 else
index c6f22acc8673453b3128f8b99ed96c37556751ab..ef4b4d946bbed61a30ef5b35c84938d73f915e50 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=8.0.10
+PKG_VERSION:=8.0.11
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=66dc4d1bc86d9c1bc255b51b79d337ed1a7a035cf71230daabbf9a4ca35795eb
+PKG_HASH:=e3e5f764ae57b31eb65244a45512f0b22d7bef05f2052b23989c053901552e16
 
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
@@ -175,6 +175,10 @@ CONFIGURE_ARGS+= \
        --with-external-pcre \
        --with-zlib="$(STAGING_DIR)/usr"
 
+ifeq ($(CONFIG_LIBC_USE_GLIBC),y)
+TARGET_LDFLAGS += -ldl
+endif
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-bcmath),)
   CONFIGURE_ARGS+= --enable-bcmath=shared
 else
index db0a301084f7cca25f04151695a947898eed02cb..968c3472cf4f9db5093c9a4375f5c5cc60456533 100644 (file)
@@ -1,9 +1,5 @@
 menu "Configuration"
 
-config PYTHON3_BLUETOOTH_SUPPORT
-       bool "Enable Bluetooth support"
-       default n
-
 config PYTHON3_HOST_PIP_CACHE_WORLD_READABLE
        bool "Ensure host pip cache is world-readable"
        default n
index 8eb28aea03869d36b9c3a861752e5084d6505ea4..93a1c335ec18906191f9a5ba2453c552fa6d4c29 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 include ../python3-version.mk
 
 PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -41,10 +41,9 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_python3-pkg-resources \
-       CONFIG_PACKAGE_python3-setuptools CONFIG_PACKAGE_python3-pip \
-       CONFIG_PYTHON3_BLUETOOTH_SUPPORT
+       CONFIG_PACKAGE_python3-setuptools CONFIG_PACKAGE_python3-pip
 
-PKG_BUILD_DEPENDS:=python3/host
+PKG_BUILD_DEPENDS:=bluez python3/host
 HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host
 
 include $(INCLUDE_DIR)/host-build.mk
@@ -92,7 +91,7 @@ endef
 define Package/python3-light
 $(call Package/python3/Default)
   TITLE:=Python $(PYTHON3_VERSION) light installation
-  DEPENDS:=+python3-base +libffi +libbz2 +PYTHON3_BLUETOOTH_SUPPORT:bluez-libs +libuuid
+  DEPENDS:=+python3-base +libffi +libbz2 +libuuid
 endef
 
 define Package/python3-light/config
@@ -149,10 +148,6 @@ EXTRA_LDFLAGS+= \
        -L$(PKG_BUILD_DIR) \
        -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
-DISABLE_BLUETOOTH:= \
-       ac_cv_header_bluetooth_bluetooth_h=no \
-       ac_cv_header_bluetooth_h=no
-
 CONFIGURE_ARGS+= \
        --enable-optimizations \
        --enable-shared \
@@ -163,8 +158,7 @@ CONFIGURE_ARGS+= \
        $(if $(CONFIG_IPV6),--enable-ipv6) \
        $(if $(findstring mips,$(CONFIG_ARCH)),,--with-lto) \
        CONFIG_SITE="$(PKG_BUILD_DIR)/config.site" \
-       OPT="$(TARGET_CFLAGS)" \
-       $(if $(CONFIG_PYTHON3_BLUETOOTH_SUPPORT),,$(DISABLE_BLUETOOTH))
+       OPT="$(TARGET_CFLAGS)"
 
 define Build/Prepare
        $(call Build/Prepare/Default)
index 3f88ac64653e16be8d5d566af34614d02c103537..ff7c5be1486e2ba90986baafd18b6edd49bec1c3 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libarchive
-PKG_VERSION:=3.5.1
-PKG_RELEASE:=1
+PKG_VERSION:=3.5.2
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.libarchive.org/downloads
-PKG_HASH:=0e17d3a8d0b206018693b27f08029b598f6ef03600c2b5d10c94ce58692e299b
+PKG_HASH:=f0b19ff39c3c9a5898a219497ababbadab99d8178acc980155c7e1271089b5a0
 
 PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
 PKG_LICENSE:=BSD-2-Clause
index e82ec751b714aef3690ee5c5215a04511a525e7b..0ab08a101ac5548fa45bc11c1fab363b020e252c 100644 (file)
@@ -8,19 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libseccomp
-PKG_VERSION:=2.5.1
-PKG_RELEASE:=1
+PKG_VERSION:=2.5.2
+PKG_RELEASE:=$(AUTORELEASE)
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/seccomp/libseccomp/releases/download/v$(PKG_VERSION)/
-PKG_HASH:=ee307e383c77aa7995abc5ada544d51c9723ae399768a97667d4cdb3c3a30d55
+PKG_HASH:=17a652dfb491d96be893960e9b791914936ee16c13b777a3caf562fe48cb87df
 
 PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
 PKG_LICENSE:=LGPL-2.1-or-later
 PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:libseccomp_project:libseccomp
 
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=gperf/host
diff --git a/libs/libseccomp/patches/010-no-code-coverage.patch b/libs/libseccomp/patches/010-no-code-coverage.patch
new file mode 100644 (file)
index 0000000..093bace
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -16,7 +16,6 @@
+ # along with this library; if not, see <http://www.gnu.org/licenses>.
+ #
+-@CODE_COVERAGE_RULES@
+ CODE_COVERAGE_OUTPUT_FILE = libseccomp.lcov.info
+ CODE_COVERAGE_OUTPUT_DIRECTORY = libseccomp.lcov.html.d
index 39f284e572d8762ef480eba102b6fd5311126b88..b5b00ea78583bbb5e908658a0198b62f83151a0b 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mutt
-PKG_VERSION:=2.1.2
+PKG_VERSION:=2.1.3
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_URL:=https://bitbucket.org/mutt/mutt/downloads/ \
                http://ftp.mutt.org/pub/mutt/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=692ab7dafa8ed1574c8e60a0b223584b11fcf55e2daaf643dbb09f269f9f3c69
+PKG_HASH:=ef759cc94b921b099a3ee88085d384fd3564c97f511e907bc83cf9812dd5e47c
 
 PKG_MAINTAINER:=Phil Eichinger <phil@zankapfel.net>
 PKG_LICENSE:=GPL-2.0-or-later
index 7db34b683bbf9ed888cf9c5308e84cadce5293f2..380760d6ec9ac0ba1c04558606e45eb6ed3b22a0 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsdist
-PKG_VERSION:=1.6.0
+PKG_VERSION:=1.6.1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
-PKG_HASH:=a7783a04d8d4ad2b0168ffaaf85ef95d5f557057b0462280684dd799d0cdd292
+PKG_HASH:=29040a43982ae1ad5b7313f081e26519ab3a58af6bced438311da3a65370a3a5
 
 PKG_MAINTAINER:=Peter van Dijk <peter.van.dijk@powerdns.com>
 PKG_LICENSE:=GPL-2.0-only
diff --git a/net/dnsdist/patches/010-time_t-check.patch b/net/dnsdist/patches/010-time_t-check.patch
deleted file mode 100644 (file)
index e8760e4..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -5044,9 +5044,6 @@ cat >>confdefs.h <<_ACEOF
- _ACEOF
--if test $ac_size -lt 8; then :
--  as_fn_error $? "size of time_t is $ac_size, which is not large enough to fix the y2k38 bug" "$LINENO" 5
--fi
-  typename=`echo time_t | sed "s/[^a-zA-Z0-9_]/_/g"`
-  { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether time_t is signed" >&5
diff --git a/net/dnsdist/patches/020-gcc11.patch b/net/dnsdist/patches/020-gcc11.patch
deleted file mode 100644 (file)
index 485beab..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/lock.hh
-+++ b/lock.hh
-@@ -20,6 +20,7 @@
-  * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-  */
- #pragma once
-+#include <mutex>
- #include <shared_mutex>
- class ReadWriteLock
index 9e3a8ba75ecc8445d613b2725509cc78676b3887..1594a6716beb4356e3101db597db40d94fdd7732 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nlbwmon
-PKG_RELEASE:=3
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/jow-/nlbwmon.git
-PKG_SOURCE_DATE:=2020-04-11.1
-PKG_SOURCE_VERSION:=34a188769750927d839ad27fbfc90c973fe7bb06
-PKG_MIRROR_HASH:=75cd4e2eccb91256a91a3d48440cb347a696db64db2e71c050d284d20f98a77c
+PKG_SOURCE_DATE:=2021-09-01
+PKG_SOURCE_VERSION:=d82c910cc3d6021567c925e767ed1fd8c3934f4b
+PKG_MIRROR_HASH:=0ec86d002c514691d7ac94fcc5055f346fe5d255cc39598c36f5ef41fab86f0a
 
 CMAKE_INSTALL:=1
 
index 3314259956c2d48d0c18793ed71bb9b2cd311dd5..93e32d180ff78afecc2a33c2d67d9b7d46ac728c 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=8.7p1
+PKG_VERSION:=8.8p1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                https://ftp.spline.de/pub/OpenBSD/OpenSSH/portable/
-PKG_HASH:=7ca34b8bb24ae9e50f33792b7091b3841d7e1b440ff57bc9fabddf01e2ed1e24
+PKG_HASH:=4590890ea9bb9ace4f71ae331785a3a5823232435161960ed5fc86588f331fe9
 
 PKG_LICENSE:=BSD ISC
 PKG_LICENSE_FILES:=LICENCE
diff --git a/net/pdns-recursor/patches/010-time_t-check.patch b/net/pdns-recursor/patches/010-time_t-check.patch
deleted file mode 100644 (file)
index 7d6b7a5..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -25,8 +25,6 @@ AC_PROG_CC
- AC_PROG_CXX
- AC_LANG([C++])
--PDNS_CHECK_TIME_T
--
- AC_DEFINE([RECURSOR], [1],
-   [This is the PowerDNS Recursor]
- )
diff --git a/net/pdns/patches/010-time_t-check.patch b/net/pdns/patches/010-time_t-check.patch
deleted file mode 100644 (file)
index ba477c5..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -26,7 +26,6 @@ AC_PROG_CC
- AC_PROG_CXX
- AC_LANG([C++])
--PDNS_CHECK_TIME_T
- PDNS_CHECK_BISON
- PDNS_CHECK_FLEX
diff --git a/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch b/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch
new file mode 100644 (file)
index 0000000..bcd7ce8
--- /dev/null
@@ -0,0 +1,26 @@
+Revert partially the upstream commit ae9ac2a1
+
+  Subject: [PATCH] meson: fix cross-compilation issues with gperf header file preprocessing
+
+  Pass c_args to the compiler when preprocessing the gperf header file,
+  they might contain important bits without which compilation/preprocessing
+  might fail (e.g. with clang on Android). cc.cmd_array() does not include
+  the c_args and we can't easily look them up from the meson.build file, so
+  we have to retrieve from the introspection info.
+
+  This is basically the Meson equivalent to commit 57103773.
+
+Revert the host_cargs related part of the patch
+
+
+--- a/src/cutout.py
++++ b/src/cutout.py
+@@ -24,7 +24,7 @@ if __name__== '__main__':
+                 break
+     cpp = args[1]
+-    ret = subprocess.run(cpp + host_cargs + [args[0].input], stdout=subprocess.PIPE, check=True)
++    ret = subprocess.run(cpp + [args[0].input], stdout=subprocess.PIPE, check=True)
+     stdout = ret.stdout.decode('utf8')
index f1443dca5fb03d67988a1ea5342ec42dd10d3618..c471ff56b3b1ff43be40df332dea17f8f9ec9f1a 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtty
-PKG_VERSION:=7.4.1
+PKG_VERSION:=8.0.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/rtty/releases/download/v$(PKG_VERSION)
-PKG_HASH:=997e5a3f0b1ce5e06d8505691ea0a9a3fd8af972f6d1b4b04f42dd03f392649f
+PKG_HASH:=b9c555005b76c1ad0f5af891964375bbdf50ee22b9a9f53ddd48d2cdb4e53b49
 
 PKG_MAINTAINER:=Jianhui Zhao <zhaojh329@gmail.com>
 PKG_LICENSE:=MIT
index b9952ce1de56ded0827bd4f6d6b042bbdcc89f3c..d7b83bd42d9a36e57a39130017d4f02d5b38c322 100644 (file)
@@ -10,5 +10,7 @@
 #   option  host        'your-server-host'  # Server host
 #   option  port        '5912'              # Server Port
 #   option  ssl         1                   # Whether to use ssl
+#   option  insecure    '1'                 # Allow insecure server connections when using SSL
 #   option  token       'your-token'        # generated by rttys
+#   option  username    'root'              # Skip a second login authentication. See man login(1) about the details
 #   option  verbose     '1'                 # verbose log
index 94b4c364b425adf060bf83383916d140081c2d6a..4725cc158f5e0985de896332c52ec821e088c39b 100644 (file)
@@ -13,7 +13,9 @@ validate_rtty_section() {
                'host:host' \
                'port:port' \
                'ssl:bool:0' \
+               'insecure:bool:0' \
                'token:maxlength(32)' \
+               'username:string' \
                'verbose:bool:0'
 }
 
@@ -48,7 +50,9 @@ start_rtty() {
        [ -n "$port" ] && procd_append_param command -p "$port"
        [ -n "$description" ] && procd_append_param command -d "$description"
        [ "$ssl" = "1" ] && procd_append_param command -s
+       [ "$insecure" = "1" ] && procd_append_param command -x
        [ -n "$token" ] && procd_append_param command -t "$token"
+       [ -n "$username" ] && procd_append_param command -f "$username"
        [ "$verbose" = "1" ] && procd_append_param command -v
        procd_set_param respawn
        procd_close_instance