update dropbear to latest latest release (v0.48.1), remove scp patch handling missing...
authorNicolas Thill <nico@openwrt.org>
Sun, 12 Mar 2006 10:19:26 +0000 (10:19 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 12 Mar 2006 10:19:26 +0000 (10:19 +0000)
SVN-Revision: 3350

openwrt/package/dropbear/Makefile
openwrt/package/dropbear/patches/160-scp_missing_macros.patch [deleted file]

index 56bc6ddff690d11aef13afed3591e862f7eb228b..75eaf6e44c6bb2f39149254d014d5eb0139f7fca 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=0.48
+PKG_VERSION:=0.48.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=89d08829eb7d47e533c552373fb87554
+PKG_MD5SUM:=ca8e53a766faec831882831364568421
 
 PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/openwrt/package/dropbear/patches/160-scp_missing_macros.patch b/openwrt/package/dropbear/patches/160-scp_missing_macros.patch
deleted file mode 100644 (file)
index 9d53251..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ruN dropbear-0.48-old/scp.c dropbear-0.48-new/scp.c
---- dropbear-0.48-old/scp.c    2006-03-09 16:06:03.000000000 +0100
-+++ dropbear-0.48-new/scp.c    2006-03-11 01:19:26.000000000 +0100
-@@ -78,6 +78,26 @@
- #include "scpmisc.h"
- #include "progressmeter.h"
-+#ifndef TIMEVAL_TO_TIMESPEC
-+#define       TIMEVAL_TO_TIMESPEC(tv, ts) {                                   \
-+      (ts)->tv_sec = (tv)->tv_sec;                                    \
-+      (ts)->tv_nsec = (tv)->tv_usec * 1000;                           \
-+}
-+#endif
-+
-+#ifndef timersub
-+#define timersub(tvp, uvp, vvp)                                        \
-+      do {                                                            \
-+              (vvp)->tv_sec = (tvp)->tv_sec - (uvp)->tv_sec;    \
-+              (vvp)->tv_usec = (tvp)->tv_usec - (uvp)->tv_usec;   \
-+              if ((vvp)->tv_usec < 0) {                          \
-+                      (vvp)->tv_sec--;                                \
-+                      (vvp)->tv_usec += 1000000;                \
-+              }                                                  \
-+      } while (/* CONSTCOND */ 0)
-+#endif /* timersub */
-+
-+
- void bwlimit(int);
- /* Struct for addargs */