[packages] openconnect: update patch (missed in r22604)
authorNicolas Thill <nico@openwrt.org>
Sat, 14 Aug 2010 09:25:37 +0000 (09:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 14 Aug 2010 09:25:37 +0000 (09:25 +0000)
SVN-Revision: 22634

net/openconnect/patches/001-change-openssl-paths.patch

index 9e0b5ce308de4bbefaa7fc24ece35ac2b08f5988..730aff604421ca76f2614f5aa5e0299084ad9823 100644 (file)
@@ -1,11 +1,11 @@
---- openconnect-2.01/Makefile  2009-06-24 12:30:34.000000000 -0500
-+++ openconnect-2.01.openwrt/Makefile  2009-09-20 18:06:39.000000000 -0500
-@@ -15,7 +15,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -15,7 +15,7 @@ endif
  # dir; there's no need to install it anywhere (we link it statically).
  ifdef OPENSSL
  SSL_CFLAGS += -I$(OPENSSL)/include
--SSL_LDFLAGS += -lz $(OPENSSL)/libssl.a $(OPENSSL)/libcrypto.a -ldl
-+SSL_LDFLAGS += -lz $(OPENSSL)/lib/libssl.a $(OPENSSL)/lib/libcrypto.a -ldl
+-SSL_LDFLAGS += $(OPENSSL)/libssl.a $(OPENSSL)/libcrypto.a
++SSL_LDFLAGS += $(OPENSSL)/lib/libssl.a $(OPENSSL)/lib/libcrypto.a
  else
  ifeq ($(wildcard /usr/include/openssl),)
  $(error "No OpenSSL in /usr/include/openssl. Cannot continue");