[packages] lsof: update to 4.86
authorLuka Perkov <luka@openwrt.org>
Sun, 10 Jun 2012 00:07:55 +0000 (00:07 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 10 Jun 2012 00:07:55 +0000 (00:07 +0000)
SVN-Revision: 32153

utils/lsof/Makefile
utils/lsof/patches/001-lsof_makefile.patch
utils/lsof/patches/002-lsof_noportmap.patch
utils/lsof/patches/003-lsof_selinux.patch [new file with mode: 0644]
utils/lsof/patches/003-lsof_uclibc.patch [deleted file]
utils/lsof/patches/004-lsof_ccv.patch [new file with mode: 0644]
utils/lsof/patches/004-lsof_selinux.patch [deleted file]
utils/lsof/patches/005-lsof_ccv.patch [deleted file]

index aad4730cdc6c55d2b299301e1d24f59d87d9de72..dd070b05d2d3fa2acb1eb69d98ff1a012a167d45 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=lsof
-PKG_VERSION:=4.81
-PKG_RELEASE:=2
+PKG_VERSION:=4.86
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).dfsg.1.orig.tar.gz
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)+dfsg.orig.tar.gz
 PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
-PKG_MD5SUM:=138b628cb1b6a3b16b32b792f77abcce
+PKG_MD5SUM:=23420509564a897b76055f9d84d19068
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).dfsg.1
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)+dfsg.orig
 
 include $(INCLUDE_DIR)/package.mk
 
index acd636a6ff9be1075b12b19aa76931f449db21f7..eb2b73519f5a08bcaf511d2162f1d5f509de98cf 100644 (file)
@@ -1,7 +1,6 @@
-diff -ru lsof_4.77.orig/lsof_4.77_src/lib/Makefile.skel lsof_4.77/lsof_4.77_src/lib/Makefile.skel
---- lsof_4.77.orig/lib/Makefile.skel   2001-02-13 03:12:22.000000000 +0100
-+++ lsof_4.77/lib/Makefile.skel        2006-11-29 13:51:44.000000000 +0100
-@@ -21,8 +21,8 @@
+--- a/lib/Makefile.skel
++++ b/lib/Makefile.skel
+@@ -21,8 +21,8 @@ OBJ= ckkv.o cvfs.o dvch.o fino.o isfn.o
  all:  ${LIB}
  
  ${LIB}:       ${OBJ}
index 5f0c17ebdb9a34f090f0c15c917b8fc0887f44a8..d0e88893c6939c276ceb7e04322089f0f190ea33 100644 (file)
@@ -1,6 +1,6 @@
---- lsof_4.77/print.orig.c     2006-08-23 13:37:43.000000000 -0600
-+++ lsof_4.77/print.c  2006-08-23 13:38:29.000000000 -0600
-@@ -148,6 +148,7 @@
+--- a/print.c
++++ b/print.c
+@@ -161,6 +161,7 @@ endnm(sz)
  static void
  fill_portmap()
  {
@@ -8,11 +8,11 @@
        char buf[128], *cp, *nm;
        CLIENT *c;
        int h, port, pr;
-@@ -266,6 +267,7 @@
+@@ -279,6 +280,7 @@ fill_portmap()
            Pth[pr][h] = pt;
        }
        clnt_destroy(c);
 +#endif
  }
+ #endif        /* !defined(HASNORPC_H) */
  
diff --git a/utils/lsof/patches/003-lsof_selinux.patch b/utils/lsof/patches/003-lsof_selinux.patch
new file mode 100644 (file)
index 0000000..7cfcb40
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Configure
++++ b/Configure
+@@ -2806,7 +2806,7 @@ return(0); }
+       LSOF_TMP1=1
+       fi      # }
+     fi        # }
+-    if test $LSOF_TMP1 -eq 1  # {
++    if 0 -eq 1        # {
+     then
+       LSOF_CFGF="$LSOF_CFGF -DHASSELINUX"
+       LSOF_CFGL="$LSOF_CFGL -lselinux"
diff --git a/utils/lsof/patches/003-lsof_uclibc.patch b/utils/lsof/patches/003-lsof_uclibc.patch
deleted file mode 100644 (file)
index e53e37b..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru lsof_4.77.orig/lsof_4.77_src/dialects/linux/dlsof.h lsof_4.77/lsof_4.77_src/dialects/linux/dlsof.h
---- lsof_4.77.orig/dialects/linux/dlsof.h      2006-03-28 00:57:14.000000000 +0200
-+++ lsof_4.77/dialects/linux/dlsof.h   2006-11-29 14:03:07.000000000 +0100
-@@ -49,7 +49,7 @@
- #include <unistd.h>
- #include <netinet/in.h>
--# if  defined(GLIBCV)
-+# if  defined(GLIBCV) || defined __UCLIBC__
- #include <netinet/tcp.h>
- # else        /* !defined(GLIBCV) */
- #include <linux/tcp.h>
diff --git a/utils/lsof/patches/004-lsof_ccv.patch b/utils/lsof/patches/004-lsof_ccv.patch
new file mode 100644 (file)
index 0000000..8f1867d
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Configure
++++ b/Configure
+@@ -2682,6 +2682,9 @@ LOCKF_OWNER4
+     if test "X$LSOF_CC" = "X" # {
+     then
+       LSOF_CC=cc
++    fi        # }
++    if test "X$LSOF_CCV" = "X"        # {
++    then
+       LSOF_CCV=`$LSOF_CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p'`
+     fi        # }
+     if test "X$LINUX_CONF_CC" = "X"   # {
diff --git a/utils/lsof/patches/004-lsof_selinux.patch b/utils/lsof/patches/004-lsof_selinux.patch
deleted file mode 100644 (file)
index 8188b38..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur lsof-4.81.dfsg.1.orig/Configure lsof-4.81.dfsg.1/Configure
---- lsof-4.81.dfsg.1.orig/Configure    2009-04-20 03:03:28.863704499 -0400
-+++ lsof-4.81.dfsg.1/Configure 2009-04-20 03:05:58.467696265 -0400
-@@ -2646,7 +2646,7 @@
-       LSOF_TMP1=1
-       fi      # }
-     fi        # }
--    if test $LSOF_TMP1 -eq 1  # {
-+    if 0 -eq 1        # {
-     then
-       LSOF_CFGF="$LSOF_CFGF -DHASSELINUX"
-       LSOF_CFGL="$LSOF_CFGL -lselinux"
diff --git a/utils/lsof/patches/005-lsof_ccv.patch b/utils/lsof/patches/005-lsof_ccv.patch
deleted file mode 100644 (file)
index 11d8820..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Configure
-+++ b/Configure
-@@ -2547,6 +2547,9 @@
-     if test "X$LSOF_CC" = "X" # {
-     then
-       LSOF_CC=cc
-+    fi        # }
-+    if test "X$LSOF_CCV" = "X"        # {
-+    then
-       LSOF_CCV=`$LSOF_CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p'`
-     fi        # }
-     LSOF_DIALECT_DIR=""