qt4: Don't build examples/demos, if they are not selected.
authorMichael Büsch <mb@bu3sch.de>
Wed, 18 Aug 2010 16:27:49 +0000 (16:27 +0000)
committerMichael Büsch <mb@bu3sch.de>
Wed, 18 Aug 2010 16:27:49 +0000 (16:27 +0000)
This also adds PKG_CONFIG_DEPENDS to force a rebuild if those options change.
This brings a significant build speed improvement.

SVN-Revision: 22705

Xorg/lib/qt4/Makefile

index 9c8d5fb7760b2babbd1097c5c46cba4a40f6f7c7..e380712ee15364f214198c746ff7ddb1d269c947 100644 (file)
@@ -20,6 +20,10 @@ PKG_SOURCE_URL:=ftp://ftp.qt.nokia.com/qt/source
 PKG_BUILD_DIR=$(BUILD_DIR)/qt-everywhere-opensource-src-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
 
+PKG_CONFIG_DEPENDS:= \
+       CONFIG_PACKAGE_qt4-demos \
+       CONFIG_PACKAGE_qt4-examples
+
 include $(INCLUDE_DIR)/package.mk
 
 # this should be moved to a more generic place later, as other packages are configured different as well depending on available nptl support
@@ -265,8 +269,8 @@ define Build/Configure
                        -no-rpath \
                        -force-pkg-config \
                        -nomake tools \
-                       -make demos \
-                       -make examples \
+                       $(if $(CONFIG_PACKAGE_qt4-demos),-make,-nomake) demos \
+                       $(if $(CONFIG_PACKAGE_qt4-examples),-make,-nomake) examples \
                        -nomake docs \
                        -nomake translations \
                        -xplatform qws/linux-openwrt-g++ \