Workaround for Neoverse N1 erratum 1130799
authorlauwal01 <lauren.wehrmeister@arm.com>
Mon, 24 Jun 2019 16:28:34 +0000 (11:28 -0500)
committerlauwal01 <lauren.wehrmeister@arm.com>
Tue, 2 Jul 2019 14:14:54 +0000 (09:14 -0500)
Neoverse N1 erratum 1130799 is a Cat B erratum [1],
present in older revisions of the Neoverse N1 processor core.
The workaround is to set a bit in the implementation defined
CPUACTLR2_EL1 system register.

[1] http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.pjdoc-466751330-10325/index.html

Change-Id: I252bc45f9733443ba0503fefe62f50fdea61da6d
Signed-off-by: Lauren Wehrmeister <lauren.wehrmeister@arm.com>
docs/design/cpu-specific-build-macros.rst
include/lib/cpus/aarch64/neoverse_n1.h
lib/cpus/aarch64/neoverse_n1.S
lib/cpus/cpu-ops.mk

index 55109dc7de6ab273b24675fd680e7a067d3a7b72..01ee416257580ae9eff1ed7dfd9bd5657eca1d18 100644 (file)
@@ -231,6 +231,9 @@ For Neoverse N1, the following errata build flags are defined :
 -  ``ERRATA_N1_1073348``: This applies errata 1073348 workaround to Neoverse-N1
    CPU. This needs to be enabled only for revision r0p0 and r1p0 of the CPU.
 
+-  ``ERRATA_N1_1130799``: This applies errata 1130799 workaround to Neoverse-N1
+   CPU. This needs to be enabled only for revision <= r2p0 of the CPU.
+
 -  ``ERRATA_N1_1315703``: This applies errata 1315703 workaround to Neoverse-N1
    CPU. This needs to be enabled only for revision <= r3p0 of the CPU.
 
index 9048f4372814bdb9f9fb1aa536671c2085cd1dbf..9042d7031db87dcb289be16b25ba13348ced9d52 100644 (file)
@@ -41,6 +41,8 @@
 
 #define NEOVERSE_N1_CPUACTLR2_EL1_BIT_2                (ULL(1) << 2)
 #define NEOVERSE_N1_CPUACTLR2_EL1_BIT_16       (ULL(1) << 16)
+#define NEOVERSE_N1_CPUACTLR2_EL1_BIT_59       (ULL(1) << 59)
+
 
 /* Instruction patching registers */
 #define CPUPSELR_EL3   S3_6_C15_C8_0
index 2d427b608a188c68f82c7fc1c54b9b1c1dd92fc1..31708a4e6372ca1ddf14e519056a4cbc58796643 100644 (file)
@@ -102,6 +102,33 @@ func check_errata_1073348
        b       cpu_rev_var_ls
 endfunc check_errata_1073348
 
+/* --------------------------------------------------
+ * Errata Workaround for Neoverse N1 Errata #1130799
+ * This applies to revision <=r2p0 of Neoverse N1.
+ * Inputs:
+ * x0: variant[4:7] and revision[0:3] of current cpu.
+ * Shall clobber: x0-x17
+ * --------------------------------------------------
+ */
+func errata_n1_1130799_wa
+       /* Compare x0 against revision r2p0 */
+       mov     x17, x30
+       bl      check_errata_1130799
+       cbz     x0, 1f
+       mrs     x1, NEOVERSE_N1_CPUACTLR2_EL1
+       orr     x1, x1, NEOVERSE_N1_CPUACTLR2_EL1_BIT_59
+       msr     NEOVERSE_N1_CPUACTLR2_EL1, x1
+       isb
+1:
+       ret     x17
+endfunc errata_n1_1130799_wa
+
+func check_errata_1130799
+       /* Applies to <=r2p0 */
+       mov     x1, #0x20
+       b       cpu_rev_var_ls
+endfunc check_errata_1130799
+
 /* --------------------------------------------------
  * Errata Workaround for Neoverse N1 Erratum 1315703.
  * This applies to revision <= r3p0 of Neoverse N1.
@@ -155,6 +182,11 @@ func neoverse_n1_reset_func
        bl      errata_n1_1073348_wa
 #endif
 
+#if ERRATA_N1_1130799
+       mov     x0, x18
+       bl      errata_n1_1130799_wa
+#endif
+
 #if ERRATA_N1_1315703
        mov     x0, x18
        bl      errata_n1_1315703_wa
@@ -218,6 +250,7 @@ func neoverse_n1_errata_report
         */
        report_errata ERRATA_N1_1043202, neoverse_n1, 1043202
        report_errata ERRATA_N1_1073348, neoverse_n1, 1073348
+       report_errata ERRATA_N1_1130799, neoverse_n1, 1130799
        report_errata ERRATA_N1_1315703, neoverse_n1, 1315703
        report_errata ERRATA_DSU_936184, neoverse_n1, dsu_936184
 
index 0d00d0adc904ef33d8890be7432ce190fdee2080..676667b6365514e299e8cdae58f44a39e8fcae92 100644 (file)
@@ -242,6 +242,10 @@ ERRATA_N1_1043202  ?=1
 # only to revision r0p0 and r1p0 of the Neoverse N1 cpu.
 ERRATA_N1_1073348      ?=0
 
+# Flag to apply erratum 1130799 workaround during reset. This erratum applies
+# only to revision <= r2p0 of the Neoverse N1 cpu.
+ERRATA_N1_1130799      ?=0
+
 # Flag to apply erratum 1315703 workaround during reset. This erratum applies
 # to revisions before r3p1 of the Neoverse N1 cpu.
 ERRATA_N1_1315703      ?=1
@@ -439,6 +443,10 @@ $(eval $(call add_define,ERRATA_N1_1043202))
 $(eval $(call assert_boolean,ERRATA_N1_1073348))
 $(eval $(call add_define,ERRATA_N1_1073348))
 
+# Process ERRATA_N1_1130799 flag
+$(eval $(call assert_boolean,ERRATA_N1_1130799))
+$(eval $(call add_define,ERRATA_N1_1130799))
+
 # Process ERRATA_N1_1315703 flag
 $(eval $(call assert_boolean,ERRATA_N1_1315703))
 $(eval $(call add_define,ERRATA_N1_1315703))