[package] libmodbus: bump to 3.0.2
authorFlorian Fainelli <florian@openwrt.org>
Tue, 27 Mar 2012 19:20:29 +0000 (19:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 27 Mar 2012 19:20:29 +0000 (19:20 +0000)
This patch updates libmodbus from version 2.0.3 to the latest stable
release 3.0.2

I needed modbus RTU and that seemed to be missing in the older version ?

Patch is also attached in case it is corrupt inline here!

Signed-off-by: Simon Gaynor <openwrt@simong.net>
SVN-Revision: 31099

libs/libmodbus/Makefile

index e379ad87cac43cf75eab74f6f49b616266c67843..833f5d40d319b6a7fe9f0860708fa95b52216135 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmodbus
-PKG_VERSION:=2.0.3
+PKG_VERSION:=3.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://github.com/downloads/stephane/libmodbus/
-PKG_MD5SUM:=0646f3edca6d7783d0356dc2fc4f9f4c
+PKG_MD5SUM:=1aaacce9d9779d3a84f7d1a75774c943
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -39,7 +39,7 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmodbus.{so*,la} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/modbus.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmodbus.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libmodbus/install