Merge pull request #332 from ecsv/batadv-2017.4
authorMoritz Warning <moritzwarning@web.de>
Wed, 13 Dec 2017 20:42:52 +0000 (21:42 +0100)
committerGitHub <noreply@github.com>
Wed, 13 Dec 2017 20:42:52 +0000 (21:42 +0100)
batman-adv 2017.4

12 files changed:
mrd6/Makefile
mrd6/patches/002-missing_netlink_defs.patch
mrd6/patches/101-Accept-default-routes-without-RTA_DST.patch
mrd6/patches/102-Metric-should-be-more-important-than-distance.patch
mrd6/patches/103-Make-build-reproducible.patch [new file with mode: 0644]
olsrd/Makefile
oonf-dlep-proxy/Makefile
oonf-dlep-radio/Makefile
oonf-olsrd2/Config.in
oonf-olsrd2/Makefile
smcroute/Makefile
smcroute/patches/001-Make-output-of-build-id-optional.patch [new file with mode: 0644]

index a20ea26ab2a1da0d79418cb1f881e655c21c6e70..c4863ed4644c4f3d52eb38e5b58211ec257f3326 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=mrd6
 PKG_SOURCE_VERSION:=c805eb33255dbc0b6647d463c6c67d1c9d3105a0
 PKG_VERSION:=2013-11-30-$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/hugosantos/mrd6.git
index 28ab711513e4fde6384b32d6c0546cd6f3c8b779..678dd35d29ca705604695b981d420744a529f9bc 100644 (file)
@@ -1,7 +1,5 @@
-Index: mrd6-0.9.5/include/mrdpriv/linux/netlink_missing_defs.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ mrd6-0.9.5/include/mrdpriv/linux/netlink_missing_defs.h    2007-09-21 13:19:06.000000000 +0200
+--- /dev/null
++++ b/include/mrdpriv/linux/netlink_missing_defs.h
 @@ -0,0 +1,41 @@
 +#include <linux/version.h>
 +
@@ -44,10 +42,8 @@ Index: mrd6-0.9.5/include/mrdpriv/linux/netlink_missing_defs.h
 +#endif
 +
 +#endif
-Index: mrd6-0.9.5/src/linux/linux_unicast_route.cpp
-===================================================================
---- mrd6-0.9.5.orig/src/linux/linux_unicast_route.cpp  2007-09-21 13:19:05.000000000 +0200
-+++ mrd6-0.9.5/src/linux/linux_unicast_route.cpp       2007-09-21 13:19:06.000000000 +0200
+--- a/src/linux/linux_unicast_route.cpp
++++ b/src/linux/linux_unicast_route.cpp
 @@ -23,6 +23,7 @@
   */
  
index 660e707756e47b2639f6f2fc2a4c3c58324fcb1d..780a9b19edc635baa3efd23aabc2abc9e77020cf 100644 (file)
@@ -7,11 +7,9 @@ Subject: [PATCH 1/2] Accept default routes without RTA_DST
  src/linux/linux_unicast_route.cpp | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)
 
-diff --git a/src/linux/linux_unicast_route.cpp b/src/linux/linux_unicast_route.cpp
-index 331a7a0..7919cc2 100644
 --- a/src/linux/linux_unicast_route.cpp
 +++ b/src/linux/linux_unicast_route.cpp
-@@ -334,7 +334,7 @@ void linux_unicast_router::handle_route_event(bool isnew, nlmsghdr *hdr) {
+@@ -335,7 +335,7 @@ void linux_unicast_router::handle_route_
        netlink_msg::parse_rtatable(tb, RTA_MAX, RTM_RTA(NLMSG_DATA(hdr)),
                                hdr->nlmsg_len - NLMSG_LENGTH(sizeof(rtmsg)));
  
@@ -20,7 +18,7 @@ index 331a7a0..7919cc2 100644
                lookup_result res;
  
                parse_prefix_rec(tb, msg->r.rtm_dst_len,
-@@ -360,7 +360,7 @@ void linux_unicast_router::handle_route_event(bool isnew, nlmsghdr *hdr) {
+@@ -361,7 +361,7 @@ void linux_unicast_router::handle_route_
                }
  
                prefix_changed(isnew, res);
@@ -29,6 +27,3 @@ index 331a7a0..7919cc2 100644
  }
  
  void linux_unicast_router::handle_intf_event(bool isnew, nlmsghdr *hdr) {
--- 
-1.9.0
-
index 359f671944ffdf8ee40839294dacf4290db76e13..ebf843d7b713a786231e2071fd65fb62721a1bb6 100644 (file)
@@ -7,11 +7,9 @@ Subject: [PATCH 2/2] Metric should be more important than distance at lookup
  src/mrib.cpp | 10 +++++-----
  1 file changed, 5 insertions(+), 5 deletions(-)
 
-diff --git a/src/mrib.cpp b/src/mrib.cpp
-index e51fed7..707d601 100644
 --- a/src/mrib.cpp
 +++ b/src/mrib.cpp
-@@ -327,16 +327,16 @@ mrib_def::mrib_node *mrib_def::prefix_lookup_y(const inet6_addr &source) const {
+@@ -327,16 +327,16 @@ mrib_def::mrib_node *mrib_def::prefix_lo
  void mrib_def::insert_prefix_in_node(mrib_node *n, prefix *p) {
        prefix *curr = n->head, *prev = 0;
  
@@ -33,6 +31,3 @@ index e51fed7..707d601 100644
                        prev = curr;
                        curr = curr->next;
                }
--- 
-1.9.0
-
diff --git a/mrd6/patches/103-Make-build-reproducible.patch b/mrd6/patches/103-Make-build-reproducible.patch
new file mode 100644 (file)
index 0000000..e0a32e6
--- /dev/null
@@ -0,0 +1,45 @@
+From deb013d93c3ce78891386637d6b3300289130df6 Mon Sep 17 00:00:00 2001
+From: Thomas Preud'homme <robotux@celest.fr>
+Date: Sun, 7 Aug 2016 22:28:50 +0100
+Subject: Make build reproducible
+
+Remove build date from the binary so that two builds on different dates
+are binary identical.
+
+Origin: upstream, https://github.com/hugosantos/mrd6/commit/14f27d5528a3e4c8e5369bdee0e35961a2491661
+Forwarded: https://github.com/hugosantos/mrd6/pull/30
+Last-Update: 2016-08-09
+Applied-Upstream: commit: 14f27d5528a3e4c8e5369bdee0e35961a2491661
+---
+ src/Makefile | 1 -
+ src/mrd.cpp  | 2 --
+ 2 files changed, 3 deletions(-)
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -185,7 +185,6 @@ endif
+ $(MRD_VERSION_CPP): $(SOURCES) Makefile Makefile.options
+       @set -e; mkdir -p $(dir $@); \
+               echo '/* This file is automatically generated */' > $(MRD_VERSION_CPP); \
+-              echo 'const char *BuildDate = "$(NOW)";' >> $(MRD_VERSION_CPP)
+ $(MODULES_CPP): Makefile Makefile.options
+       @set -e; mkdir -p $(dir $@); \
+--- a/src/mrd.cpp
++++ b/src/mrd.cpp
+@@ -75,7 +75,6 @@
+ mrd *g_mrd = 0;
+-extern const char *BuildDate;
+ static const char *VersionInfo = "mrd6 0.10.0";
+ static const char *defaultconffiles[] = {
+@@ -2335,7 +2334,6 @@ bool mrd::socket_regs(base_stream &out,
+ void mrd::show_base_info(base_stream &out) const {
+       out.xprintf("Version: %s\n", VersionInfo);
+-      out.xprintf("Build date: %s\n", BuildDate);
+ }
+ bool mrd::show_info(base_stream &out, const std::vector<std::string> &ctx) {
index 00786f0815e0c43b13b04b23b3587b9916a084e0..4aaccb2ca51a3eae116883ec052cf17162bf1b3c 100644 (file)
@@ -119,7 +119,7 @@ endef
 
 define Package/olsrd-mod-pud
   $(call Package/olsrd/template)
-  DEPENDS:=olsrd +libgps +ncurses
+  DEPENDS:=olsrd +libgps
   TITLE:=Position Update Distribution plugin
 endef
 
index 2f36eaabe6b0974bb3c23db08b81610e424269f3..28e16fd3e8b77aa6ab9ad92abe9ab06408c57b96 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-proxy
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index ac1f19c47e095e8b2d278cbd4fd89742cb3f6668..4357e5b6fa58f2fc2cbb2f826012c6bc19c12551 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-radio
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 7cda51805c8159de564d7112744c1f9551b2580b..1cc037aff3ebc9a2a1ea2d2c94857d62b8b28006 100644 (file)
                        The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
                default n
 
+       config OONF_GENERIC_HTTP
+               bool "http plugin enabled"
+               help
+                       The HTTP plugin allows HTTP access to all telnet commands.
+               default n
+
+       config OONF_OLSRV2_MPR
+               bool "MPR plugin enabled"
+               help
+                       The MPR plugin reduce the routing graph to limit the overhead of the OLSRv2 protocol
+               default n
+
        endmenu
index 9b8e988509bc039a2375d7aa2c524a15ed4582d6..727bd16721b09ad05a36780fa52f5d0bc5a6b29f 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-olsrd2
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -24,9 +24,14 @@ CMAKE_OPTIONAL_PLUGINS:= $(subst $(SPACE),;,$(strip \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_ROUTE_MODIFIER)),route_modifier,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
+        $(if $(filter y,$(CONFIG_OONF_OLSRV2_MPR)),mpr,) \
+        $(if $(filter y,$(CONFIG_OONF_GENERIC_HTTP)),http,) \
     ))
 
-CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
+BUILD_TYPE:= $(if $(filter y,$(CONFIG_DEBUG)),Debug,Release)
+
+CMAKE_OPTIONS=-D CMAKE_BUILD_TYPE:String=$(BUILD_TYPE) \
+              -D OONF_NO_WERROR:Bool=true \
               -D OONF_LOGGING_LEVEL:String=debug \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \
index 1a5a2027b8133df893f0ea66039ab87d49561d88..a11bfd97a9ee530658a7df91526e8ee5092b567f 100644 (file)
@@ -8,13 +8,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smcroute
 PKG_VERSION:=2.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-2.0+
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=ftp://troglobit.com/smcroute/
 PKG_MD5SUM:=cbf478e52ab9ae411adca41b9d22f68a
 
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/smcroute
diff --git a/smcroute/patches/001-Make-output-of-build-id-optional.patch b/smcroute/patches/001-Make-output-of-build-id-optional.patch
new file mode 100644 (file)
index 0000000..bffecc9
--- /dev/null
@@ -0,0 +1,65 @@
+Author: Micha Lenk <micha@lenk.info>
+Date: Thu, 7 May 2015 21:54:31 +0200
+Description: Make output of build id optional
+ With free software, anyone can inspect the source code for malicious flaws.
+ But the software is often provided as binary packages to its users. The idea
+ of “deterministic” or “reproducible” builds is to empower anyone to verify
+ that no flaws have been introduced during the build process by reproducing
+ byte-for-byte identical binary packages from a given source.  See also:
+ https://wiki.debian.org/ReproducibleBuilds
+ .
+ Prior to this change a timestamp generated at build time is included in the
+ output of 'smcroute -v'. As a result the binary is unreproducible.
+ .
+ With this change, users that still want 'smcroute -v' to include a build id
+ can run './configure --enable-build-id' to get the build id back (or even
+ specify a custom build id).
+Origin: upstream, https://github.com/troglobit/smcroute/commit/73f6f14907f709e40689216291621ad26cd22ecd
+Bug-Debian: https://bugs.debian.org/784694
+Last-Update: 2017-08-08
+
+---
+ configure.ac | 9 ++++++++-
+ smcroute.c   | 6 +++++-
+ 2 files changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 556d958..eb4a291 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -181,7 +181,14 @@ AC_COMPILE_IFELSE(
+   [AC_MSG_RESULT(no)])
+ # Add build number to config.h.in
+-AC_DEFINE_UNQUOTED([BUILD], "`date +%y%m%d`", [Build number, abbreviated date.])
++AC_ARG_ENABLE([build-id],
++  [AS_HELP_STRING([--enable-build-id@<:@=ID@:>@],
++              [show build id in output of 'smcroute -v'])],
++  [AS_IF([test "x$enableval" = "xyes" ],
++    [build_id=`date +%y%m%d`],
++    [build_id=$enableval])
++   AC_DEFINE_UNQUOTED([BUILD], "$build_id", [Build number, abbreviated date.])])
++
+ # Checks for library functions.
+ AC_FUNC_FORK
+diff --git a/smcroute.c b/smcroute.c
+index 7bd3c72..0287458 100644
+--- a/smcroute.c
++++ b/smcroute.c
+@@ -46,7 +46,11 @@ static const char *conf_file = SMCROUTE_SYSTEM_CONF;
+ extern char *__progname;
+ static const char version_info[] =
+-      "SMCRoute version " PACKAGE_VERSION " build " BUILD "\n";
++      "SMCRoute version " PACKAGE_VERSION
++#ifdef BUILD
++        " build " BUILD
++#endif
++        "\n";
+ static const char usage_info[] =
+       "Usage: smcroute [OPTIONS]... [ARGS]...\n"
+-- 
+2.11.0
+