keepalived: make the use of libnl optional
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 2 Feb 2016 15:57:14 +0000 (17:57 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Sat, 31 Dec 2016 10:07:56 +0000 (12:07 +0200)
keepalived seems to work fine without it.
There is fall-back code that kicks in when it's not present.

So, we will build against (or pull) the libnl package only
if there is another package that pulls it.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
net/keepalived/Makefile

index 4f8dc8294adf75adffa028d351777be94d6f00be..b29b111a5fbf2b9250a95e7401ed205972f64ff6 100644 (file)
@@ -29,7 +29,7 @@ define Package/keepalived
   CATEGORY:=Network
   TITLE:=Failover and monitoring daemon for LVS clusters
   URL:=http://www.keepalived.org/
-  DEPENDS:=+libnl-genl +libopenssl
+  DEPENDS:=+PACKAGE_libnl-genl:libnl-genl +libopenssl
 endef
 
 define Package/keepalived/description