libseccomp: workaround a recursive dependency
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Wed, 15 May 2019 12:42:47 +0000 (09:42 -0300)
committerRosen Penev <rosenp@gmail.com>
Tue, 13 Aug 2019 22:21:46 +0000 (15:21 -0700)
DEPENDS:=@!arc is causing a recursive dependency because of the optional
selection of libseccomp by util/lxc.  The workaround hides the package
in Package/libseccomp/config instead.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
(cherry-picked from e29483d7e202b06c49b3ede7fbb63c2ba1879321)

libs/libseccomp/Makefile

index 9817f0eb57085c46eeb76886c35d2c8038783042..a53b95ac7744dfacd2450ec24e5dfada28f0090a 100644 (file)
@@ -26,6 +26,11 @@ PKG_CONFIG_DEPENDS:= \
 
 include $(INCLUDE_DIR)/package.mk
 
+# This is done instead of DEPENDS:=@!arc to avoid a recursive dependency when
+# the library is conditionally selected by util/lxc.
+define Package/libseccomp/config
+  depends on !arc
+endef
 
 define Package/libseccomp/Default
   SUBMENU:=
@@ -46,7 +51,6 @@ endef
 define Package/libseccomp
 $(call Package/libseccomp/Default)
   TITLE+= (library)
-  DEPENDS+=
 endef
 
 define Package/libseccomp/description