mariadb: add dependency on libaio for arc as well
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 24 Jun 2019 08:36:20 +0000 (10:36 +0200)
committerRosen Penev <rosenp@gmail.com>
Tue, 13 Aug 2019 22:01:28 +0000 (15:01 -0700)
Now that libaio compiles on arc targets we need to add the dependency to
libaio on these targets as well.

resolves #9298

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
(cherry-picked from c571c37e5c7e68eb9c431869f09a83d2a7ffaea2)

utils/mariadb/Makefile

index 086f10c22baf00431f4fb614e8fd44b076d606fa..3ac0859aea895301187d4cad2566471f3761977a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mariadb
 PKG_VERSION:=10.1.41
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL := \
@@ -267,7 +267,7 @@ define Package/mariadb-server
   $(call Package/mariadb/Default)
   DEPENDS:= \
          $(MARIADB_COMMON_DEPENDS) \
-         +!arc:libaio \
+         +libaio \
          +liblzma \
          +libpcre \
          +resolveip