utils/luci-app-lxc: removed application 4025/head
authordanrl <mail@danrl.com>
Fri, 17 Feb 2017 10:06:06 +0000 (11:06 +0100)
committerdanrl <mail@danrl.com>
Fri, 17 Feb 2017 10:06:06 +0000 (11:06 +0100)
Moved over to the LuCI repository.

Signed-off-by: Dan Luedtke <mail@danrl.com>
utils/luci-app-lxc/Makefile [deleted file]
utils/luci-app-lxc/files/controller/lxc.lua [deleted file]
utils/luci-app-lxc/files/lxc.config [deleted file]
utils/luci-app-lxc/files/model/cbi/lxc.lua [deleted file]
utils/luci-app-lxc/files/view/lxc.htm [deleted file]
utils/luci-app-lxc/files/www/luci-static/resources/cbi/green.gif [deleted file]
utils/luci-app-lxc/files/www/luci-static/resources/cbi/purple.gif [deleted file]
utils/luci-app-lxc/files/www/luci-static/resources/cbi/red.gif [deleted file]

diff --git a/utils/luci-app-lxc/Makefile b/utils/luci-app-lxc/Makefile
deleted file mode 100644 (file)
index 026f714..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=luci-app-lxc
-PKG_RELEASE:=20161030
-
-PKG_LICENSE:=Apache-2.0
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/luci-app-lxc
-  SECTION:=luci
-  CATEGORY:=LuCI
-  SUBMENU:=3. Applications
-  TITLE:=LXC management Web UI
-  DEPENDS:=+luci-mod-admin-full +lxc +lxc-create +liblxc +rpcd-mod-lxc +getopt +xz
-  MAINTAINER:=Petar Koretic <petar.koretic@sartura.hr>
-endef
-
-define Package/luci-app-lxc/description
- This package will install LXC management Web UI.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/luci-app-lxc/install
-       $(INSTALL_DIR) $(1)/usr/lib/lua/luci/controller/
-       $(INSTALL_BIN) \
-               ./files/controller/lxc.lua \
-               $(1)/usr/lib/lua/luci/controller/
-
-       $(INSTALL_DIR) $(1)/usr/lib/lua/luci/view/
-       $(INSTALL_DATA) \
-               ./files/view/lxc.htm \
-               $(1)/usr/lib/lua/luci/view/
-
-       $(INSTALL_DIR) $(1)/usr/lib/lua/luci/model/cbi/
-       $(INSTALL_BIN) \
-               ./files/model/cbi/lxc.lua \
-               $(1)/usr/lib/lua/luci/model/cbi/
-
-       $(INSTALL_DIR) $(1)/etc/config/
-       $(INSTALL_DATA) \
-               ./files/lxc.config \
-               $(1)/etc/config/lxc
-
-       $(INSTALL_DIR) $(1)/www
-       $(CP) -R \
-               ./files/www/* \
-               $(1)/www
-endef
-
-$(eval $(call BuildPackage,luci-app-lxc))
diff --git a/utils/luci-app-lxc/files/controller/lxc.lua b/utils/luci-app-lxc/files/controller/lxc.lua
deleted file mode 100644 (file)
index ea7adba..0000000
+++ /dev/null
@@ -1,167 +0,0 @@
---[[
-
-LuCI LXC module
-
-Copyright (C) 2014, Cisco Systems, Inc.
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-Author: Petar Koretic <petar.koretic@sartura.hr>
-
-]]--
-
-module("luci.controller.lxc", package.seeall)
-
-require "ubus"
-local conn = ubus.connect()
-if not conn then
-    error("Failed to connect to ubus")
-end
-
-
-function fork_exec(command)
-       local pid = nixio.fork()
-       if pid > 0 then
-               return
-       elseif pid == 0 then
-               -- change to root dir
-               nixio.chdir("/")
-
-               -- patch stdin, out, err to /dev/null
-               local null = nixio.open("/dev/null", "w+")
-               if null then
-                       nixio.dup(null, nixio.stderr)
-                       nixio.dup(null, nixio.stdout)
-                       nixio.dup(null, nixio.stdin)
-                       if null:fileno() > 2 then
-                               null:close()
-                       end
-               end
-
-               -- replace with target command
-               nixio.exec("/bin/sh", "-c", command)
-       end
-end
-
-function index()
-       page = node("admin", "services", "lxc")
-       page.target = cbi("lxc")
-       page.title = _("LXC Containers")
-       page.order = 70
-
-       page = entry({"admin", "services", "lxc_create"}, call("lxc_create"), nil)
-       page.leaf = true
-
-       page = entry({"admin", "services", "lxc_action"}, call("lxc_action"), nil)
-       page.leaf = true
-
-       page = entry({"admin", "services", "lxc_get_downloadable"}, call("lxc_get_downloadable"), nil)
-       page.leaf = true
-
-       page = entry({"admin", "services", "lxc_configuration_get"}, call("lxc_configuration_get"), nil)
-       page.leaf = true
-
-       page = entry({"admin", "services", "lxc_configuration_set"}, call("lxc_configuration_set"), nil)
-       page.leaf = true
-
-end
-
-function lxc_get_downloadable()
-       luci.http.prepare_content("application/json")
-
-       local f = io.popen('uname -m', 'r')
-       local target = f:read('*a')
-       f:close()
-       target = target:gsub("^%s*(.-)%s*$", "%1")
-
-       local templates = {}
-
-       local f = io.popen('lxc-create -n just_want_to_list_available_lxc_templates -t download -- --list', 'r')
-
-       for line in f:lines() do
-               local dist,version = line:match("^(%S+)%s+(%S+)%s+" .. target .. "%s+default%s+%S+$")
-               if dist~=nil and version~=nil then templates[#templates + 1] = dist .. ":" .. version end
-       end
-
-       f:close()
-       luci.http.write_json(templates)
-end
-
-function lxc_create(lxc_name, lxc_template)
-       luci.http.prepare_content("text/plain")
-
-       local uci = require("uci").cursor()
-
-       local url = uci:get("lxc", "lxc", "url")
-
-       if not pcall(dofile, "/etc/openwrt_release") then
-               return luci.http.write("1")
-       end
-
-       local f = io.popen('uname -m', 'r')
-       local target = f:read('*a')
-       f:close()
-       target = target:gsub("^%s*(.-)%s*$", "%1")
-
-       local lxc_dist = lxc_template:gsub("(.*):(.*)", '%1')
-       local lxc_release = lxc_template:gsub("(.*):(.*)", '%2')
-
-       local data = conn:call("lxc", "create", { name = lxc_name, template = "download", args = { "--server", url,  "--no-validate", "--dist", lxc_dist, "--release", lxc_release, "--arch", target } } )
-
-       luci.http.write(data)
-end
-
-function lxc_action(lxc_action, lxc_name)
-       luci.http.prepare_content("application/json")
-
-       local data, ec = conn:call("lxc", lxc_action, lxc_name and { name = lxc_name} or {} )
-
-       luci.http.write_json(ec and {} or data)
-end
-
-function lxc_get_config_path()
-       local f = io.open("/etc/lxc/lxc.conf", "r")
-       local content = f:read("*all")
-       f:close()
-       local ret = content:match('^%s*lxc.lxcpath%s*=%s*([^%s]*)')
-       if ret then
-               return ret .. "/"
-       else
-               return "/srv/lxc/"
-       end
-end
-
-function lxc_configuration_get(lxc_name)
-       luci.http.prepare_content("text/plain")
-
-       local f = io.open(lxc_get_config_path() .. lxc_name .. "/config", "r")
-       local content = f:read("*all")
-       f:close()
-
-       luci.http.write(content)
-end
-
-function lxc_configuration_set(lxc_name)
-       luci.http.prepare_content("text/plain")
-
-       local lxc_configuration = luci.http.formvalue("lxc_configuration")
-
-       if lxc_configuration == nil then
-               return luci.http.write("1")
-       end
-
-       local f, err = io.open(lxc_get_config_path() .. lxc_name .. "/config","w+")
-       if not f then
-               return luci.http.write("2")
-       end
-
-       f:write(lxc_configuration)
-       f:close()
-
-       luci.http.write("0")
-end
-
diff --git a/utils/luci-app-lxc/files/lxc.config b/utils/luci-app-lxc/files/lxc.config
deleted file mode 100644 (file)
index 5572c73..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-#
-# lxc uci configuration
-#
-
-config lxc 'lxc'
-       option url 'virtualwrt.org/containers/'
diff --git a/utils/luci-app-lxc/files/model/cbi/lxc.lua b/utils/luci-app-lxc/files/model/cbi/lxc.lua
deleted file mode 100644 (file)
index ac0fdff..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---[[
-
-LuCI LXC module
-
-Copyright (C) 2014, Cisco Systems, Inc.
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-Author: Petar Koretic <petar.koretic@sartura.hr>
-
-]]--
-
-local fs = require "nixio.fs"
-
-m = Map("lxc", translate("LXC Containers"))
-
-if fs.access("/etc/config/lxc") then
-       m:section(SimpleSection).template = "lxc"
-
-       s = m:section(TypedSection, "lxc", translate("Options"))
-       s.anonymous = true
-       s.addremove = false
-
-       s:option(Value, "url", translate("Containers URL"))
-end
-
-return m
diff --git a/utils/luci-app-lxc/files/view/lxc.htm b/utils/luci-app-lxc/files/view/lxc.htm
deleted file mode 100644 (file)
index edfff8e..0000000
+++ /dev/null
@@ -1,458 +0,0 @@
-<%#
-
-LuCI LXC module
-
-Copyright (C) 2014, Cisco Systems, Inc.
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-Author: Petar Koretic <petar.koretic@sartura.hr>
-
--%>
-
-<fieldset class="cbi-section">
-       <legend><%:Available Containers%></legend>
-       <div class="cbi-section-node">
-               <table id="t_lxc_list" class="cbi-section-table">
-                       <tr class="cbi-section-table-titles">
-                               <th class="cbi-section-table-cell"><%:Name%></th>
-                               <th class="cbi-section-table-cell"><%:Status%></th>
-                               <th class="cbi-section-table-cell"><%:Actions%></th>
-                       </tr>
-               </table>
-       </div>
-</fieldset>
-
-<fieldset class="cbi-section">
-       <span id="lxc-list-output"></span>
-</fieldset>
-
-<hr/>
-<fieldset class="cbi-section">
-       <legend><%:Create New Container%></legend>
-       <div class="cbi-section-node">
-               <table id="t_lxc_create" class="cbi-section-table">
-                       <tr class="cbi-section-table-titles">
-                               <th class="cbi-section-table-cell"><%:Name%></th>
-                               <th class="cbi-section-table-cell"><%:Template%></th>
-                               <th class="cbi-section-table-cell"><%:Actions%></th>
-                       </tr>
-                       <tr id="tr_holder">
-                               <td>
-                                       <input type="text" id="tx_name" placeholder="<%:Enter new name%>" value='' />
-                               </td>
-                               <td>
-                                       <select id="s_template" class="cbi-input-select cbi-button">
-                                       </select>
-                               </td>
-                               <td>
-                                       <input type="button" id="bt_create" value="<%:Create%>" onclick="lxc_create(tr_holder)" class="cbi-button cbi-button-add" />
-                                       <span id="lxc-add-loader" style="display:inline-block; width:16px; height:16px; margin:0 5px"></span>
-                               </td>
-                       </tr>
-               </table>
-       </div>
-</fieldset>
-
-<fieldset class="cbi-section">
-       <span id="lxc-add-output"></span>
-</fieldset>
-
-<hr/>
-
-<script type="text/javascript" src="<%=resource%>/cbi.js"></script>
-<script type="text/javascript">//<![CDATA[
-
-       window.img = { "red" : "<%=resource%>/cbi/red.gif", "green" : "<%=resource%>/cbi/green.gif", "purple" : "<%=resource%>/cbi/purple.gif" }
-       window.states = {  "STOPPED" : "red", "RUNNING" : "green", "FROZEN" : "purple"}
-
-       var t_lxc_list = document.getElementById('t_lxc_list');
-       var loader_html = '<img src="<%=resource%>/icons/loading.gif" alt="<%:Loading%>" width="16" height="16" style="vertical-align:middle" /> ';
-       var timeout_msg = 0
-       var output_list = document.getElementById("lxc-list-output")
-       var output_add = document.getElementById("lxc-add-output")
-       var loader_add = document.getElementById("lxc-add-loader")
-
-       function lxc_create(tr)
-       {
-               var lxc_name = tr.querySelector("#tx_name").value.trim()
-               var lxc_template = tr.querySelector("#s_template").value
-               var bt_create = tr.querySelector("#bt_create")
-
-               if (t_lxc_list.querySelector("[data-id='" + lxc_name + "']") != null)
-                       return info_message(output_add, "Container with that name already exists!", 4000)
-
-               bt_create.disabled = true
-               output_add.innerHTML = ''
-
-               if (!lxc_name || !lxc_name.length)
-               {
-                       bt_create.disabled = false
-                       return info_message(output_add, "Name cannot be empty!", 4000)
-               }
-
-               loading(loader_add)
-
-               new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_create/' + '%h/%h'.format(lxc_name, lxc_template) , null,
-               function(x)
-               {
-                       bt_create.disabled = false
-                       loading(loader_add, 0)
-
-                       if (!x)
-                               info_message(output_add, "Container creation failed!")
-               })
-       }
-
-       function lxc_create_template(lxc_name, lxc_state)
-       {
-               var info_row = t_lxc_list.querySelector("#empty")
-               if (info_row)
-                       t_lxc_list.deleteRow(1)
-
-               var actions = ''
-               actions += '<input type="button" onclick="action_handler(this)" data-action="start" value="<%:Start%>" class="cbi-button cbi-button-apply" />'
-               actions+= '<input type="button" onclick="action_handler(this)" data-action="stop" value="<%:Stop%>" class="cbi-button cbi-button-reset" />'
-               actions+= '<input type="button" onclick="action_handler(this)" data-action="destroy" value="<%:Delete%>" class="cbi-button cbi-button-remove" />'
-               actions+= ' <select class="cbi-input-select cbi-button" onchange="action_more_handler(this)">\
-                                               <option selected disabled>more</option>\
-                                               <option>configure</option>\
-                                               <option>freeze</option>\
-                                               <option>unfreeze</option>\
-                                               <option>reboot</option>\
-                                       </select>'
-               actions+= '<span data-loader style="display:inline-block; width:16px; height:16px; margin:0 5px"></span>'
-
-               var row = t_lxc_list.insertRow(-1)
-               var cell = row.insertCell(-1)
-               cell.innerHTML = '%q%h%q'.format("<strong>", lxc_name, "</strong>")
-               cell.width = "30%"
-               cell.setAttribute("data-id", lxc_name)
-
-               cell = row.insertCell(-1)
-               cell.width = "20%"
-               cell.innerHTML = "<img src='"+window.img[lxc_state]+"'/>"
-
-               cell = row.insertCell(-1)
-               cell.width = "50%"
-               cell.innerHTML = actions
-       }
-
-       function action_handler(self)
-       {
-               var action = self.getAttribute("data-action");
-
-               var bt_action = self
-               var lxc_name = self.parentNode.parentNode.children[0].getAttribute('data-id')
-               var status_img = self.parentNode.parentNode.querySelector('img')
-               var loader = self.parentNode.querySelector('[data-loader]')
-
-               bt_action.disabled = true
-
-               if (action == "stop")
-               {
-                       loading(loader)
-
-                       new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/' + '%h/%h'.format(action, lxc_name), null,
-                       function(x, ec)
-                       {
-                               loading(loader, 0)
-                               bt_action.disabled = false
-
-                               if (!x || ec)
-                                       return info_message(output_list,"Action failed!")
-
-                               set_status(status_img, "red")
-
-                       });
-               }
-
-               else if (action == "start")
-               {
-                       loading(loader)
-
-                       new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/' + '%h/%h'.format(action, lxc_name), null,
-                       function(x, data)
-                       {
-                               loading(loader, 0)
-                               bt_action.disabled = false
-
-                               //FIXME: uncomment after fixing 'lxc-start'
-                               if (!x /*|| ec */)
-                                       return info_message(output_list,"Action failed!")
-
-                               //FIXME: uncomment after fixing 'lxc-start'
-                               //set_status(status_img, "green")
-                       });
-               }
-
-               else if (action == "destroy")
-               {
-                       if (!confirm("This will completely remove LXC container from the disk. Are you sure? (container will be stopped if running)"))
-                               return
-
-                       loading(loader)
-
-                       new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/' + '%h/%h'.format(action, lxc_name), null,
-                       function(x, ec)
-                       {
-                               loading(loader, 0)
-                               bt_action.disabled = false
-
-                               if (!x || ec)
-                                       return info_message(output_list,"Action failed!")
-
-                               var row = self.parentNode.parentNode
-                               row.parentNode.removeChild(row)
-
-                       });
-               }
-       }
-
-       function lxc_configure_handler(self)
-       {
-               var td = self.parentNode
-               var textarea = td.querySelector('[data-id]')
-               var lxc_name = textarea.getAttribute('data-id')
-               var lxc_configuration = textarea.value
-
-               new XHR().post('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_configuration_set/' + lxc_name, "lxc_configuration=" + encodeURIComponent(lxc_configuration) ,
-               function(x)
-               {
-                       if (!x || x.responseText != "0")
-                               return info_message(output_list,"Action failed!")
-
-                       info_message(output_list,"LXC configuration updated")
-                       var row = td.parentNode
-                       row.parentNode.removeChild(row)
-               })
-       }
-
-       function lxc_rename_template(lxc_name)
-       {
-               var h = '\
-                       <input data-id="'+ lxc_name + '" type="text" placeholder="Enter new name" /> \
-                       <input data-id="bt_confirm" onclick="lxc_rename_handler(this)" type="button" class="cbi-button" value="Confirm" />'
-
-               return h
-       }
-
-       function lxc_configure_template(lxc_name, lxc_configuration)
-       {
-               var h = '\
-                       <textarea data-id="'+ lxc_name + '" rows="20" style="width:100%">'+ lxc_configuration +'</textarea> \
-                       <input data-id="bt_confirm" onclick="lxc_configure_handler(this)" type="button" class="cbi-button" value="Confirm" />'
-
-               return h
-       }
-
-       function action_more_handler(self)
-       {
-               var lxc_name = self.parentNode.parentNode.querySelector('[data-id]').getAttribute('data-id')
-               var loader = self.parentNode.parentNode.querySelector('[data-loader]')
-
-               var option = self.options[self.selectedIndex].text
-
-               self.value = "more"
-
-               switch (option)
-               {
-                       case "configure":
-                               var tr = document.createElement('tr')
-                               var row = self.parentNode.parentNode
-                               var next_row = row.nextSibling
-                               if (next_row && next_row.getAttribute('data-action') !== null)
-                                       row.parentNode.removeChild(next_row)
-
-                               new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_configuration_get/' + lxc_name, null,
-                               function(x)
-                               {
-                                       tr.innerHTML="<td colspan='" + row.cells.length + "'>" + lxc_configure_template(lxc_name, x.responseText) + "</td>"
-                                       tr.setAttribute('data-action','')
-                                       row.parentNode.insertBefore(tr, row.nextSibling)
-                               })
-
-                       break
-
-                       case "freeze":
-                               var tr = self.parentNode.parentNode
-                               var img = tr.querySelector('img')
-                               if(img.getAttribute('src') != window.img["green"])
-                                       return info_message(output_list,"Container is not running!")
-
-                               loading(loader)
-                               new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/' + '%h/%h'.format(option, lxc_name), null,
-                               function(x, ec)
-                               {
-                                       loading(loader, 0)
-                                       if (!x || ec)
-                                               return info_message(output_list,"Action failed!")
-
-                                       set_status(img, "purple")
-                               })
-
-                       break
-
-                       case "unfreeze":
-                               var tr = self.parentNode.parentNode
-                               var img = tr.querySelector('img')
-
-                               if(img.getAttribute('src') != window.img["purple"])
-                                       return info_message(output_list,"Container is not frozen!")
-
-                               loading(loader)
-                               new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/' + '%h/%h'.format(option, lxc_name), null,
-                               function(x, ec)
-                               {
-                                       loading(loader, 0)
-                                       if (!x || ec)
-                                               return info_message(output_list,"Action failed!")
-
-                                       set_status(img, "green")
-                               })
-
-                       break
-
-                       case "reboot":
-                               var tr = self.parentNode.parentNode
-                               var img = tr.querySelector('img')
-                               if(img.getAttribute('src') != window.img["green"])
-                                       return info_message(output_list,"Container is not running!")
-
-                               if (!confirm("Are you sure?"))
-                                       return
-
-                               loading(loader)
-                               new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/' + '%h/%h'.format(option, lxc_name), null,
-                               function(x, ec)
-                               {
-                                       loading(loader, 0)
-                                       if (!x || ec)
-                                               return info_message(output_list,"Action failed!")
-
-                                       info_message(output_list,"LXC rebooted")
-                               })
-                       break
-               }
-
-       }
-
-       function set_empty(t_lxc_list)
-       {
-               if (document.getElementById('empty') !== null)
-                       return
-
-               var row_count = t_lxc_list.rows.length;
-               while(--row_count) t_lxc_list.deleteRow(row_count);
-
-               var row = t_lxc_list.insertRow(-1);
-               row.id = 'empty'
-               var cell = row.insertCell(0);
-               cell.colSpan = 4;
-               cell.innerHTML = '<em><br />There are no containers available yet.</em>';
-       }
-
-       function lxc_list_update()
-       {
-               XHR.poll(4, '<%=luci.dispatcher.build_url("admin", "services")%>/lxc_action/list', null,
-               function(x, data)
-               {
-                       if (!x) return;
-
-                       var lxc_count = Object.keys(data).length
-                       if (!data || !lxc_count)
-                               return set_empty(t_lxc_list)
-
-                       if (document.getElementById('empty') !== null)
-                               t_lxc_list.deleteRow(1);
-
-                       var lxcs = t_lxc_list.querySelectorAll('td[data-id]')
-                       var lxc_name_table = {}
-                       for (var i = 0, len = lxcs.length; i < len; i++)
-                       {
-                               var lxc_name = lxcs[i].getAttribute('data-id')
-                               if (!(lxc_name in data))
-                               {
-                                       var row = t_lxc_list.querySelector("[data-id='" + lxc_name + "']").parentNode
-                                       row.parentNode.removeChild(row)
-                                       continue
-                               }
-
-                               lxc_name_table[lxc_name] = lxcs[i].parentNode.querySelector('img')
-                       }
-
-                       for(var key in data)
-                       {
-                               var lxc_name = key
-                               var state = window.states[data[key]]
-
-                               if (!(lxc_name in lxc_name_table))
-                                       lxc_create_template(lxc_name, state)
-
-                               else if (state != get_status(lxc_name_table[lxc_name]))
-                                       set_status(lxc_name_table[lxc_name], state)
-                       }
-
-               })
-       }
-
-       function loading(elem, state)
-       {
-               state = (typeof state === 'undefined') ? 1 : state
-
-               if (state === 1)
-                       elem.innerHTML = loader_html
-               else
-                       setTimeout(function() { elem.innerHTML = ''}, 1000)
-       }
-
-       function set_status(elem, state)
-       {
-               state = (typeof state === 'undefined') ? 1 : state
-
-               setTimeout(function() { elem.setAttribute('src', window.img[state])}, 300)
-       }
-
-       function get_status(elem)
-       {
-               var src = elem.getAttribute('src')
-
-               for (var i in img)
-               {
-                       if (img[i] == src)
-                               return i
-               }
-       }
-
-       function info_message(output, msg, timeout)
-       {
-               timeout = timeout || 3000
-               output.innerHTML = msg
-               clearTimeout(timeout_msg)
-               timeout_msg = setTimeout(function(){ output.innerHTML=""}, timeout);
-       }
-
-       lxc_list_update()
-
-       new XHR().get('<%=luci.dispatcher.build_url("admin", "services")%>/lxc_get_downloadable', null,
-       function(x, data)
-       {
-               if (!x) return;
-
-               var lxc_count = Object.keys(data).length
-               if (!data || !lxc_count) return;
-               var select = document.getElementById("s_template");
-               for(var key in data)
-               {
-                       var option = document.createElement('option');
-                       option.value = data[key];
-                       option.text = data[key].replace(/[_:]/g, ' ');
-                       select.add(option, -1);
-               }
-       })
-
-//]]></script>
diff --git a/utils/luci-app-lxc/files/www/luci-static/resources/cbi/green.gif b/utils/luci-app-lxc/files/www/luci-static/resources/cbi/green.gif
deleted file mode 100644 (file)
index d09febf..0000000
Binary files a/utils/luci-app-lxc/files/www/luci-static/resources/cbi/green.gif and /dev/null differ
diff --git a/utils/luci-app-lxc/files/www/luci-static/resources/cbi/purple.gif b/utils/luci-app-lxc/files/www/luci-static/resources/cbi/purple.gif
deleted file mode 100644 (file)
index f0d68cc..0000000
Binary files a/utils/luci-app-lxc/files/www/luci-static/resources/cbi/purple.gif and /dev/null differ
diff --git a/utils/luci-app-lxc/files/www/luci-static/resources/cbi/red.gif b/utils/luci-app-lxc/files/www/luci-static/resources/cbi/red.gif
deleted file mode 100644 (file)
index c1b39bb..0000000
Binary files a/utils/luci-app-lxc/files/www/luci-static/resources/cbi/red.gif and /dev/null differ