emailrelay: Remove unnecessary OpenSSL engine include 7842/head
authorRosen Penev <rosenp@gmail.com>
Wed, 2 Jan 2019 07:35:26 +0000 (23:35 -0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 2 Jan 2019 07:35:26 +0000 (23:35 -0800)
There's no usage of any ENGINE APIs and trying to include the header
breaks compilation with ENGINE support disabled.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
mail/emailrelay/Makefile
mail/emailrelay/patches/020-openssl-engine.patch [new file with mode: 0644]

index d0ef0e341384ed39b09e52c715d4d3ab68e1099f..cef6e22c08d2d1526a4bf39a641d4743f7966fb1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=emailrelay
 PKG_VERSION:=2.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
 PKG_SOURCE_URL:=@SF/emailrelay/$(PKG_VERSION)
diff --git a/mail/emailrelay/patches/020-openssl-engine.patch b/mail/emailrelay/patches/020-openssl-engine.patch
new file mode 100644 (file)
index 0000000..d10d694
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/gssl/gssl_openssl.cpp
++++ b/src/gssl/gssl_openssl.cpp
+@@ -32,7 +32,6 @@
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
+ #include <openssl/rand.h>
+-#include <openssl/engine.h>
+ #include <openssl/conf.h>
+ #include <openssl/evp.h>
+ #include <openssl/hmac.h>