tvheadend: fix build on macos
authorSergey V. Lobanov <sergey@lobanov.in>
Sat, 29 Jan 2022 20:12:53 +0000 (23:12 +0300)
committerRosen Penev <rosenp@gmail.com>
Sat, 29 Jan 2022 21:32:16 +0000 (13:32 -0800)
tvheadend configure/make files detect Darwin build host and changes
build logic, but it fails compilation for OpenWrt target (Linux)

This patch explicitly specifies Linux as a target platfrom

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
multimedia/tvheadend/Makefile

index 53c326baca0e04c22404a6b01c6568c9511bf1cc..f5656dc416d79c5aa19fd340cdd15ebcd96373c4 100644 (file)
@@ -187,7 +187,17 @@ endif
 ##     CONFIGURE_ARGS += --disable-libopus
 ##endif
 
+#required to cross-compile hdhomerun on non-Linux build host
+MAKE_FLAGS += \
+       OS=Linux
+
+#required to always have "build.linux" dir, not "build.darwin" on macos
+CONFIGURE_VARS += \
+       PLATFORM=linux
+
+#--platfrom=linux is required to cross-compile tvheadend on non-Linux build host
 CONFIGURE_ARGS += \
+       --platform=linux \
        --arch=$(ARCH) \
        --disable-libsystemd_daemon \
        --disable-dbus_1 \