Add asterisk18-chan-sccp-b package.
authorJiri Slachta <slachta@cesnet.cz>
Thu, 4 Apr 2013 16:07:51 +0000 (18:07 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Thu, 4 Apr 2013 16:07:51 +0000 (18:07 +0200)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
asterisk-chan-sccp-b/Makefile [new file with mode: 0644]
asterisk-chan-sccp-b/files/sccp.openwrt.conf [new file with mode: 0644]
asterisk-chan-sccp-b/patches/200-register-file-version.patch [new file with mode: 0644]
asterisk-chan-sccp-b/patches/300-stdarg.patch [new file with mode: 0644]

diff --git a/asterisk-chan-sccp-b/Makefile b/asterisk-chan-sccp-b/Makefile
new file mode 100644 (file)
index 0000000..406c59e
--- /dev/null
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=asterisk18-chan-sccp-b
+PKG_REV=3004
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://svn.code.sf.net/p/chan-sccp-b/code/trunk
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/asterisk18-chan-sccp-b
+  SUBMENU:=Telephony
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=SCCP channel provider for asterisk
+  URL:=http://chan-sccp-b.net.sourceforge.net/
+  MAINTAINER:=Hans Zandbelt <hans.zandbelt@gmail.com>
+  DEPENDS:=+asterisk18 +libltdl
+endef
+
+define Package/asterisk18-chan-sccp-b/description
+ SCCP channel provider for asterisk. It delivers extended functionality for SCCP phones over chan_skinny delivered
+ by asterisk by default.
+endef
+
+CONFIGURE_ARGS += \
+       --with-asterisk=$(STAGING_DIR)/usr/include/asterisk-1.8
+
+define Build/Compile
+       $(MAKE) -C "$(PKG_BUILD_DIR)" \
+               CFLAGS="$(CFLAGS) -DLOW_MEMORY" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/asterisk18-chan-sccp-b/conffiles
+/etc/asterisk/sccp.conf
+endef
+
+define Package/asterisk18-chan-sccp-b/install
+       $(INSTALL_DIR) $(1)/etc/asterisk
+       $(INSTALL_BIN)  ./files/sccp.openwrt.conf $(1)/etc/asterisk/sccp.conf
+       $(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_sccp.so $(1)/usr/lib/asterisk/modules/
+endef
+
+$(eval $(call BuildPackage,asterisk18-chan-sccp-b))
diff --git a/asterisk-chan-sccp-b/files/sccp.openwrt.conf b/asterisk-chan-sccp-b/files/sccp.openwrt.conf
new file mode 100644 (file)
index 0000000..c59f4cd
--- /dev/null
@@ -0,0 +1,89 @@
+[general]
+servername = Openwrt
+keepalive = 60
+debug = core
+context = default
+dateformat = D/M/Y
+bindaddr = 192.168.1.1
+port = 2000
+disallow=all
+allow=ulaw
+allow=alaw
+allow=gsm
+firstdigittimeout = 16
+digittimeout = 6
+autoanswer_ring_time = 1
+musicclass=default
+language=en
+deny=0.0.0.0/0.0.0.0
+permit=192.168.1.0/255.255.255.0
+protocolversion=17
+
+hotline_enabled=yes
+hotline_context=default
+hotline_extension=111
+
+[SEP001122334455]
+type = device
+description = Phone Number One
+devicetype = 7940
+button = line, 111
+button = line, 113@01:shared
+button = speeddial,Phone 2 Line 1, 112, 112@hint
+
+[SEP00a1a2a3a4a5]
+type = device
+description = Phone Number Two
+devicetype = 7960
+button = line, 112
+button = line, 113@01:shared
+button = speeddial,Phone 1 Line 1, 111, 111@hint
+
+[111]
+id = 1000
+type = line
+pin = 1234
+label = Phone 1 Line 1
+description = Line 111
+mailbox = 10111
+cid_name = Phone 1 CID
+cid_num = 111
+accountcode=79111
+callgroup=1
+pickupgroup=1
+context = default
+incominglimit = 2
+vmnum = 600
+trnsfvm = 1000
+
+[112]
+id = 1001
+type = line
+pin = 1234
+label = Phone 2 Line 1
+description = Line 112
+mailbox = 10112
+cid_name = Phone 2 CID
+cid_num = 112
+accountcode=79112
+callgroup=1
+pickupgroup=1
+context = default
+incominglimit = 2
+vmnum = 600
+trnsfvm = 1000
+
+[113]
+id = 1002
+type = line
+pin = 1234
+label = SharedLine 1
+description = Line 113
+mailbox = 10113
+cid_name = Shared
+cid_num = 113
+accountcode=79113
+incominglimit = 2
+vmnum = 600
+trnsfvm = 1000
+
diff --git a/asterisk-chan-sccp-b/patches/200-register-file-version.patch b/asterisk-chan-sccp-b/patches/200-register-file-version.patch
new file mode 100644 (file)
index 0000000..81ca9d3
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/src/chan_sccp.h
++++ b/src/chan_sccp.h
+@@ -127,15 +127,7 @@ extern "C" {
+ #        define CHECK_LEAKS()
+ #    endif
+-#    define SCCP_FILE_VERSION(file, version) \
+-      static void __attribute__((constructor)) __register_file_version(void) \
+-      { \
+-              pbx_register_file_version(file, version); \
+-      } \
+-      static void __attribute__((destructor)) __unregister_file_version(void) \
+-      { \
+-              pbx_unregister_file_version(file); \
+-      }
++#    define SCCP_FILE_VERSION(file, version) 
+ #    define DEV_ID_LOG(x) x ? x->id : "SCCP"
diff --git a/asterisk-chan-sccp-b/patches/300-stdarg.patch b/asterisk-chan-sccp-b/patches/300-stdarg.patch
new file mode 100644 (file)
index 0000000..be91ed7
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/chan_sccp.h
++++ b/src/chan_sccp.h
+@@ -32,6 +32,7 @@ extern "C" {
+ #include "common.h"
+ #include <poll.h>
+ #include "asterisk/compiler.h"
++#include <stdarg.h>
+ #include "asterisk/lock.h"
+ #include "asterisk/abstract_jb.h"