screen: fix musl compatibility 1408/head
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Jun 2015 18:00:08 +0000 (20:00 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Jun 2015 18:01:59 +0000 (20:01 +0200)
Add missing `os.h` include to `utmp.c` to pull in the required `utmp.h` header.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
utils/screen/Makefile
utils/screen/patches/200-musl-compat.patch [new file with mode: 0644]

index 3adfb0ab3309ea591c4628d586c7ed7606818d92..634121424c3032f7d602c829826b3bbd6b9408ea 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=screen
 PKG_VERSION:=4.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/screen
diff --git a/utils/screen/patches/200-musl-compat.patch b/utils/screen/patches/200-musl-compat.patch
new file mode 100644 (file)
index 0000000..2586bb9
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/utmp.c
++++ b/utmp.c
+@@ -33,6 +33,7 @@
+ #include "config.h"
+ #include "screen.h"
+ #include "extern.h"
++#include "os.h"
+ #ifdef HAVE_UTEMPTER
+ #include <utempter.h>