lang: lua-mosquitto: import new package 672/head
authorKarl Palsson <karlp@remake.is>
Thu, 18 Dec 2014 17:12:56 +0000 (17:12 +0000)
committerKarl Palsson <karlp@remake.is>
Thu, 18 Dec 2014 17:14:01 +0000 (17:14 +0000)
Based on released version of lua binding to libmosquitto.
Advantages compared to lua-mqtt:
* qos 1/2 support
* substantially faster

Signed-off-by: Karl Palsson <karlp@remake.is>
lang/lua-mosquitto/Makefile [new file with mode: 0644]

diff --git a/lang/lua-mosquitto/Makefile b/lang/lua-mosquitto/Makefile
new file mode 100644 (file)
index 0000000..a8d625f
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-mosquitto
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_SOURCE:=v$(PKG_VERSION).tar.gz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/flukso/$(PKG_NAME)/archive/
+PKG_MD5SUM:=fd26fa08fc855ba4a66ce521fe5aae13
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+    SUBMENU:=Lua
+    SECTION:=lang
+    CATEGORY:=Languages
+    TITLE:=Lua-mosquitto
+    DEPENDS:=+libmosquitto +lua
+    MAINTAINER:=Karl Palsson <karlp@remake.is>
+endef
+
+define Package/$(PKG_NAME)/description
+       Lua bindings to libmosquitto
+endef
+
+define Package/$(PKG_NAME)/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mosquitto.so $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))