tang: update to 11
authorRosen Penev <rosenp@gmail.com>
Thu, 16 Dec 2021 23:15:22 +0000 (15:15 -0800)
committerRosen Penev <rosenp@gmail.com>
Fri, 17 Dec 2021 08:58:19 +0000 (00:58 -0800)
Remove upstreamed patch.

Install tang-show-keys.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/tang/Makefile
utils/tang/patches/010-http.patch [deleted file]

index 33f5ec4f53d24fb1cef00d12b056a3c3da8065da..cbd8febec5dc889d530415af5ccba4bfc8735dd5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tang
-PKG_VERSION:=10
+PKG_VERSION:=11
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/latchset/$(PKG_NAME)/releases/download/v$(PKG_VERSION)/
-PKG_HASH:=082f17e031708ab5e2f88c9b767d228bcf92a0d089fdb164d4ae93845cbd2a48
+PKG_HASH:=ef5d3ae56030f20c290594b9be89ad9ec469dd385676595e1c7a2bfdc3f45d8f
 
 PKG_MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
 PKG_LICENSE:=GPL-3.0-or-later
@@ -41,11 +41,13 @@ define Package/tang/conffiles
 endef
 
 define Package/tang/install
+       $(INSTALL_DIR)  $(1)/usr/bin
        $(INSTALL_DIR)  $(1)/usr/libexec
        $(INSTALL_DIR)  $(1)/etc/xinetd.d/
-       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/libexec/tangd*   $(1)/usr/libexec/
-       $(INSTALL_BIN)  ./files/tangdw                          $(1)/usr/libexec/
-       $(CP)           ./files/tangdx                          $(1)/etc/xinetd.d/
+       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/bin/tang-show-keys       $(1)/usr/bin/
+       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/libexec/tangd*           $(1)/usr/libexec/
+       $(INSTALL_BIN)  ./files/tangdw                                  $(1)/usr/libexec/
+       $(CP)           ./files/tangdx                                  $(1)/etc/xinetd.d/
 endef
 
 define Package/tang/postinst
diff --git a/utils/tang/patches/010-http.patch b/utils/tang/patches/010-http.patch
deleted file mode 100644 (file)
index 12ca666..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -54,7 +54,7 @@ compiler = meson.get_compiler('c')
- if not compiler.has_header('http_parser.h',args : '-I/usr/local/include')
-   error('http-parser devel files not found.')
- endif
--http_parser = compiler.find_library('http_parser',dirs:['/usr/lib','/usr/local/lib'])
-+http_parser = compiler.find_library('http_parser')
- licenses = ['COPYING']
- libexecbins = []