SPM: Introduce SMC handlers for SPCI and SPRT
authorAntonio Nino Diaz <antonio.ninodiaz@arm.com>
Thu, 8 Nov 2018 14:12:40 +0000 (14:12 +0000)
committerAntonio Nino Diaz <antonio.ninodiaz@arm.com>
Tue, 11 Dec 2018 13:45:41 +0000 (13:45 +0000)
Change-Id: I2ae9b3bb686c41b2e138132a7bed107925ac861e
Signed-off-by: Antonio Nino Diaz <antonio.ninodiaz@arm.com>
bl31/aarch64/runtime_exceptions.S
include/services/spci_svc.h [new file with mode: 0644]
include/services/sprt_svc.h [new file with mode: 0644]
services/std_svc/spm/spci.c [new file with mode: 0644]
services/std_svc/spm/spm.mk
services/std_svc/spm/sprt.c [new file with mode: 0644]

index 77bd63ec083baaebc39f505fa47dd2126986cf34..ab61e8ccfab25e1f3e361c35ba175f4c2d6163df 100644 (file)
@@ -382,8 +382,16 @@ smc_handler64:
         */
        tbz     x0, #(FUNCID_NAMESPACE_SHIFT + 1), compat_or_vendor
 
-       /* Namespaces SPRT and SPCI currently unimplemented */
+       /* Namespace is b'10 (SPRT) or b'11 (SPCI) */
+#if ENABLE_SPM
+       tst     x0, #(1 << FUNCID_NAMESPACE_SHIFT)
+       adr     x15, spci_smc_handler
+       adr     x16, sprt_smc_handler
+       csel    x15, x15, x16, ne
+       b       prepare_enter_handler
+#else
        b       smc_unknown
+#endif
 
 compat_or_vendor:
 
@@ -401,6 +409,8 @@ compat_or_vendor:
 
        load_rt_svc_desc_pointer
 
+prepare_enter_handler:
+
 #endif /* SMCCC_MAJOR_VERSION */
 
        /*
diff --git a/include/services/spci_svc.h b/include/services/spci_svc.h
new file mode 100644 (file)
index 0000000..eae4fb7
--- /dev/null
@@ -0,0 +1,121 @@
+/*
+ * Copyright (c) 2018, Arm Limited. All rights reserved.
+ *
+ * SPDX-License-Identifier: BSD-3-Clause
+ */
+
+#ifndef SPCI_SVC_H
+#define SPCI_SVC_H
+
+#include <smccc.h>
+#include <utils_def.h>
+
+/* SPCI_VERSION helpers */
+
+#define SPCI_VERSION_MAJOR             U(0)
+#define SPCI_VERSION_MAJOR_SHIFT       16
+#define SPCI_VERSION_MAJOR_MASK                U(0x7FFF)
+#define SPCI_VERSION_MINOR             U(1)
+#define SPCI_VERSION_MINOR_SHIFT       0
+#define SPCI_VERSION_MINOR_MASK                U(0xFFFF)
+#define SPCI_VERSION_FORM(major, minor)        ((((major) & SPCI_VERSION_MAJOR_MASK)  \
+                                               << SPCI_VERSION_MAJOR_SHIFT) | \
+                                       ((minor) & SPCI_VERSION_MINOR_MASK))
+#define SPCI_VERSION_COMPILED          SPCI_VERSION_FORM(SPCI_VERSION_MAJOR, \
+                                                         SPCI_VERSION_MINOR)
+
+/* Definitions to build the complete SMC ID */
+
+#define SPCI_FID_MISC_FLAG             (U(0) << 27)
+#define SPCI_FID_MISC_SHIFT            U(20)
+#define SPCI_FID_MISC_MASK             U(0x7F)
+
+#define SPCI_FID_TUN_FLAG              (U(1) << 27)
+#define SPCI_FID_TUN_SHIFT             U(24)
+#define SPCI_FID_TUN_MASK              U(0x7)
+
+#define SPCI_SMC(spci_fid)     ((FUNCID_NAMESPACE_SPCI << FUNCID_NAMESPACE_SHIFT) | \
+                                (U(1) << 31) | (spci_fid))
+#define SPCI_MISC_32(misc_fid) ((SMC_32 << FUNCID_CC_SHIFT) |  \
+                                SPCI_FID_MISC_FLAG |           \
+                                SPCI_SMC((misc_fid) << SPCI_FID_MISC_SHIFT))
+#define SPCI_MISC_64(misc_fid) ((SMC_64 << FUNCID_CC_SHIFT) |  \
+                                SPCI_FID_MISC_FLAG |           \
+                                SPCI_SMC((misc_fid) << SPCI_FID_MISC_SHIFT))
+#define SPCI_TUN_32(tun_fid)   ((SMC_32 << FUNCID_CC_SHIFT) |  \
+                                SPCI_FID_TUN_FLAG |            \
+                                SPCI_SMC((tun_fid) << SPCI_FID_TUN_SHIFT))
+#define SPCI_TUN_64(tun_fid)   ((SMC_64 << FUNCID_CC_SHIFT) |  \
+                                SPCI_FID_TUN_FLAG |            \
+                                SPCI_SMC((tun_fid) << SPCI_FID_TUN_SHIFT))
+
+/* SPCI miscellaneous functions */
+
+#define SPCI_FID_VERSION                       U(0x0)
+#define SPCI_FID_SERVICE_HANDLE_OPEN           U(0x2)
+#define SPCI_FID_SERVICE_HANDLE_CLOSE          U(0x3)
+#define SPCI_FID_SERVICE_MEM_REGISTER          U(0x4)
+#define SPCI_FID_SERVICE_MEM_UNREGISTER                U(0x5)
+#define SPCI_FID_SERVICE_MEM_PUBLISH           U(0x6)
+#define SPCI_FID_SERVICE_REQUEST_BLOCKING      U(0x7)
+#define SPCI_FID_SERVICE_REQUEST_START         U(0x8)
+#define SPCI_FID_SERVICE_GET_RESPONSE          U(0x9)
+#define SPCI_FID_SERVICE_RESET_CLIENT_STATE    U(0xA)
+
+/* SPCI tunneling functions */
+
+#define SPCI_FID_SERVICE_TUN_REQUEST_START     U(0x0)
+#define SPCI_FID_SERVICE_REQUEST_RESUME                U(0x1)
+#define SPCI_FID_SERVICE_TUN_REQUEST_BLOCKING  U(0x2)
+
+/* Complete SMC IDs and associated values */
+
+#define SPCI_VERSION                           SPCI_MISC_32(SPCI_FID_VERSION)
+
+#define SPCI_SERVICE_HANDLE_OPEN               SPCI_MISC_32(SPCI_FID_SERVICE_HANDLE_OPEN)
+#define SPCI_SERVICE_HANDLE_OPEN_NOTIFY_BIT    U(1)
+
+#define SPCI_SERVICE_HANDLE_CLOSE              SPCI_MISC_32(SPCI_FID_SERVICE_HANDLE_CLOSE)
+
+#define SPCI_SERVICE_MEM_REGISTER_AARCH32      SPCI_MISC_32(SPCI_FID_SERVICE_MEM_REGISTER)
+#define SPCI_SERVICE_MEM_REGISTER_AARCH64      SPCI_MISC_64(SPCI_FID_SERVICE_MEM_REGISTER)
+
+#define SPCI_SERVICE_MEM_UNREGISTER_AARCH32    SPCI_MISC_32(SPCI_FID_SERVICE_MEM_UNREGISTER)
+#define SPCI_SERVICE_MEM_UNREGISTER_AARCH64    SPCI_MISC_64(SPCI_FID_SERVICE_MEM_UNREGISTER)
+
+#define SPCI_SERVICE_MEM_PUBLISH_AARCH32       SPCI_MISC_32(SPCI_FID_SERVICE_MEM_PUBLISH)
+#define SPCI_SERVICE_MEM_PUBLISH_AARCH64       SPCI_MISC_64(SPCI_FID_SERVICE_MEM_PUBLISH)
+
+#define SPCI_SERVICE_REQUEST_BLOCKING_AARCH32  SPCI_MISC_32(SPCI_FID_SERVICE_REQUEST_BLOCKING)
+#define SPCI_SERVICE_REQUEST_BLOCKING_AARCH64  SPCI_MISC_64(SPCI_FID_SERVICE_REQUEST_BLOCKING)
+
+#define SPCI_SERVICE_REQUEST_START_AARCH32     SPCI_MISC_32(SPCI_FID_SERVICE_REQUEST_START)
+#define SPCI_SERVICE_REQUEST_START_AARCH64     SPCI_MISC_64(SPCI_FID_SERVICE_REQUEST_START)
+
+#define SPCI_SERVICE_GET_RESPONSE_AARCH32      SPCI_MISC_32(SPCI_FID_SERVICE_GET_RESPONSE)
+#define SPCI_SERVICE_GET_RESPONSE_AARCH64      SPCI_MISC_64(SPCI_FID_SERVICE_GET_RESPONSE)
+
+#define SPCI_SERVICE_RESET_CLIENT_STATE_AARCH32        SPCI_MISC_32(SPCI_FID_SERVICE_RESET_CLIENT_STATE)
+#define SPCI_SERVICE_RESET_CLIENT_STATE_AARCH64        SPCI_MISC_64(SPCI_FID_SERVICE_RESET_CLIENT_STATE)
+
+#define SPCI_SERVICE_TUN_REQUEST_START_AARCH32 SPCI_TUN_32(SPCI_FID_SERVICE_TUN_REQUEST_START)
+#define SPCI_SERVICE_TUN_REQUEST_START_AARCH64 SPCI_TUN_64(SPCI_FID_SERVICE_TUN_REQUEST_START)
+
+#define SPCI_SERVICE_REQUEST_RESUME_AARCH32    SPCI_TUN_32(SPCI_FID_SERVICE_REQUEST_RESUME)
+#define SPCI_SERVICE_REQUEST_RESUME_AARCH64    SPCI_TUN_64(SPCI_FID_SERVICE_REQUEST_RESUME)
+
+#define SPCI_SERVICE_TUN_REQUEST_BLOCKING_AARCH32 SPCI_TUN_32(SPCI_FID_SERVICE_TUN_REQUEST_BLOCKING)
+#define SPCI_SERVICE_TUN_REQUEST_BLOCKING_AARCH64 SPCI_TUN_64(SPCI_FID_SERVICE_TUN_REQUEST_BLOCKING)
+
+/* SPCI error codes. */
+
+#define SPCI_SUCCESS            0
+#define SPCI_NOT_SUPPORTED     -1
+#define SPCI_INVALID_PARAMETER -2
+#define SPCI_NO_MEMORY         -3
+#define SPCI_BUSY              -4
+#define SPCI_QUEUED            -5
+#define SPCI_DENIED            -6
+#define SPCI_NOT_PRESENT       -7
+
+#endif /* SPCI_SVC_H */
diff --git a/include/services/sprt_svc.h b/include/services/sprt_svc.h
new file mode 100644 (file)
index 0000000..ccc4eb3
--- /dev/null
@@ -0,0 +1,62 @@
+/*
+ * Copyright (c) 2018, Arm Limited. All rights reserved.
+ *
+ * SPDX-License-Identifier: BSD-3-Clause
+ */
+
+#ifndef SPRT_SVC_H
+#define SPRT_SVC_H
+
+#include <smccc.h>
+#include <utils_def.h>
+
+/* SPRT_VERSION helpers */
+
+#define SPRT_VERSION_MAJOR             U(0)
+#define SPRT_VERSION_MAJOR_SHIFT       16
+#define SPRT_VERSION_MAJOR_MASK                U(0x7FFF)
+#define SPRT_VERSION_MINOR             U(1)
+#define SPRT_VERSION_MINOR_SHIFT       0
+#define SPRT_VERSION_MINOR_MASK                U(0xFFFF)
+#define SPRT_VERSION_FORM(major, minor)        ((((major) & SPRT_VERSION_MAJOR_MASK)  \
+                                               << SPRT_VERSION_MAJOR_SHIFT) | \
+                                       ((minor) & SPRT_VERSION_MINOR_MASK))
+#define SPRT_VERSION_COMPILED          SPRT_VERSION_FORM(SPRT_VERSION_MAJOR, \
+                                                         SPRT_VERSION_MINOR)
+
+/* SPRT function IDs */
+
+#define SPRT_FID_VERSION               U(0x0)
+#define SPRT_FID_PUT_RESPONSE          U(0x1)
+#define SPRT_FID_YIELD                 U(0x5)
+#define SPRT_FID_PANIC                 U(0x7)
+#define SPRT_FID_MEMORY_PERM_ATTR_GET  U(0xB)
+#define SPRT_FID_MEMORY_PERM_ATTR_SET  U(0xC)
+
+#define SPRT_FID_MASK                  U(0xFF)
+
+/* Definitions to build the complete SMC ID */
+
+#define SPRT_SMC_64(sprt_fid)  ((FUNCID_NAMESPACE_SPRT << FUNCID_NAMESPACE_SHIFT) | \
+                                (U(1) << 31) | ((sprt_fid) & SPRT_FID_MASK) | \
+                                (SMC_64 << FUNCID_CC_SHIFT))
+#define SPRT_SMC_32(sprt_fid)  ((FUNCID_NAMESPACE_SPRT << FUNCID_NAMESPACE_SHIFT) | \
+                                (U(1) << 31) | ((sprt_fid) & SPRT_FID_MASK) | \
+                                (SMC_32 << FUNCID_CC_SHIFT))
+
+/* Complete SMC IDs */
+
+#define SPRT_VERSION                           SPRT_SMC_32(SPRT_FID_VERSION)
+#define SPRT_PUT_RESPONSE_AARCH64              SPRT_SMC_64(SPRT_FID_PUT_RESPONSE)
+#define SPRT_YIELD_AARCH64                     SPRT_SMC_64(SPRT_FID_YIELD)
+#define SPRT_PANIC_AARCH64                     SPRT_SMC_64(SPRT_FID_PANIC)
+#define SPRT_MEMORY_PERM_ATTR_GET_AARCH64      SPRT_SMC_64(SPRT_FID_MEMORY_PERM_ATTR_GET)
+#define SPRT_MEMORY_PERM_ATTR_SET_AARCH64      SPRT_SMC_64(SPRT_FID_MEMORY_PERM_ATTR_SET)
+
+/* SPRT error codes. */
+
+#define SPRT_SUCCESS            0
+#define SPRT_NOT_SUPPORTED     -1
+#define SPRT_INVALID_PARAMETER -2
+
+#endif /* SPRT_SVC_H */
diff --git a/services/std_svc/spm/spci.c b/services/std_svc/spm/spci.c
new file mode 100644 (file)
index 0000000..603523f
--- /dev/null
@@ -0,0 +1,52 @@
+/*
+ * Copyright (c) 2018, Arm Limited. All rights reserved.
+ *
+ * SPDX-License-Identifier: BSD-3-Clause
+ */
+
+#include <debug.h>
+#include <smccc.h>
+#include <smccc_helpers.h>
+#include <spci_svc.h>
+#include <utils.h>
+
+#include "spm_private.h"
+
+/*******************************************************************************
+ * This function handles all SMCs in the range reserved for SPCI.
+ ******************************************************************************/
+uint64_t spci_smc_handler(uint32_t smc_fid, uint64_t x1, uint64_t x2,
+                         uint64_t x3, uint64_t x4, void *cookie, void *handle,
+                         uint64_t flags)
+{
+       uint32_t spci_fid;
+
+       /* SPCI only supported from the Non-secure world for now */
+       if (is_caller_non_secure(flags) == SMC_FROM_SECURE) {
+               SMC_RET1(handle, SMC_UNK);
+       }
+
+       if ((smc_fid & SPCI_FID_TUN_FLAG) == 0) {
+
+               /* Miscellaneous calls */
+
+               spci_fid = (smc_fid >> SPCI_FID_MISC_SHIFT) & SPCI_FID_MISC_MASK;
+
+               switch (spci_fid) {
+
+               case SPCI_FID_VERSION:
+                       SMC_RET1(handle, SPCI_VERSION_COMPILED);
+
+               default:
+                       break;
+               }
+
+       } else {
+
+               /* Tunneled calls */
+
+       }
+
+       WARN("SPCI: Unsupported call 0x%08x\n", smc_fid);
+       SMC_RET1(handle, SPCI_NOT_SUPPORTED);
+}
index 0e77086045c7ea5f9eb166628659c8cf9915a9e7..889c77d25b1ba8e02f263078ba9c12717ff3a379 100644 (file)
@@ -14,10 +14,15 @@ endif
 SPM_SOURCES    :=      $(addprefix services/std_svc/spm/,      \
                        ${ARCH}/spm_helpers.S                   \
                        ${ARCH}/spm_shim_exceptions.S           \
-                       spm_main.c                              \
                        sp_setup.c                              \
-                       sp_xlat.c)
+                       sp_xlat.c                               \
+                       spci.c                                  \
+                       spm_main.c                              \
+                       sprt.c)
+
 
+# Force SMC Calling Convention 2 when using SPM
+SMCCC_MAJOR_VERSION    :=      2
 
 # Let the top-level Makefile know that we intend to include a BL32 image
 NEED_BL32              :=      yes
diff --git a/services/std_svc/spm/sprt.c b/services/std_svc/spm/sprt.c
new file mode 100644 (file)
index 0000000..8d0c510
--- /dev/null
@@ -0,0 +1,48 @@
+/*
+ * Copyright (c) 2018, Arm Limited. All rights reserved.
+ *
+ * SPDX-License-Identifier: BSD-3-Clause
+ */
+
+#include <arch_helpers.h>
+#include <assert.h>
+#include <context_mgmt.h>
+#include <debug.h>
+#include <smccc.h>
+#include <smccc_helpers.h>
+#include <sprt_svc.h>
+#include <utils.h>
+
+#include "spm_private.h"
+
+/*******************************************************************************
+ * This function handles all SMCs in the range reserved for SPRT.
+ ******************************************************************************/
+uint64_t sprt_smc_handler(uint32_t smc_fid, uint64_t x1, uint64_t x2,
+                         uint64_t x3, uint64_t x4, void *cookie, void *handle,
+                         uint64_t flags)
+{
+       /* SPRT only supported from the Secure world */
+       if (is_caller_non_secure(flags) == SMC_FROM_NON_SECURE) {
+               SMC_RET1(handle, SMC_UNK);
+       }
+
+       assert(handle == cm_get_context(SECURE));
+
+       /*
+        * Only S-EL0 partitions are supported for now. Make the next ERET into
+        * the partition jump directly to S-EL0 instead of S-EL1.
+        */
+       cm_set_elr_spsr_el3(SECURE, read_elr_el1(), read_spsr_el1());
+
+       switch (smc_fid) {
+       case SPRT_VERSION:
+               SMC_RET1(handle, SPRT_VERSION_COMPILED);
+
+       default:
+               break;
+       }
+
+       WARN("SPRT: Unsupported call 0x%08x\n", smc_fid);
+       SMC_RET1(handle, SPRT_NOT_SUPPORTED);
+}